Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Developer
nelson0511
Posts: 23
Registered: ‎10-01-2013
My Device: devloper

error message: You are trying to run an appliacation built for the device on the smulator.please rebuild your application for the simulator.

I got this message when trying to run my app on the simulator. I am using cascades. I have downloaded the simulator and vmware. the controller will conect to the simulator. What can i do to be able to run my application?I have my build configuration set to Device-debug. Is that what it should be?

Please use plain text.
Developer
peter9477
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10

Re: error message: You are trying to run an appliacation built for the device on the smulator.please rebuild your application for the simulator.

You don't want the build configuration to be Device-anything. That builds for the device, which is ARM architecture. The simulator is x86 architecture, so you need to use one of the Simulator- build configurations.

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Please use plain text.
New Developer
nelson0511
Posts: 23
Registered: ‎10-01-2013
My Device: devloper

Re: error message: You are trying to run an appliacation built for the device on the smulator.please rebuild your application for the simulator.

when i change it the build configuration from device-debug to simulator-debug and try to run it it pops up with a message saying that it has encountered a problem. and it still wont run

Please use plain text.
Developer
peter9477
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10

Re: error message: You are trying to run an appliacation built for the device on the smulator.please rebuild your application for the simulator.

I can't help with that, but you definitely want that configuration if you'll be running on the simulator.

I suggest a new thread for the new issue (with more details than just "encountered a problem", assuming it says anything other than exactly that).

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Please use plain text.
Developer
bmorr
Posts: 331
Registered: ‎04-13-2013
My Device: Z10

Re: error message: You are trying to run an appliacation built for the device on the smulator.please rebuild your application for the simulator.

Try cleaning the project and rebuilding it.  If that doesn't work try deleting the project from the IDE (NOT delete from the computer just from the IDE) and try to re-import the project.  If that doesn't work try restarting the IDE or try restarting your computer.

 

Just to make sure, you're right clicking on the project and choosing build as -> simulator?

Please use plain text.
New Developer
nelson0511
Posts: 23
Registered: ‎10-01-2013
My Device: devloper

Re: error message: You are trying to run an appliacation built for the device on the smulator.please rebuild your application for the simulator.

how do you clean the project and rebuild it? how do you re-import the project?

Please use plain text.
Developer
bmorr
Posts: 331
Registered: ‎04-13-2013
My Device: Z10

Re: error message: You are trying to run an appliacation built for the device on the smulator.please rebuild your application for the simulator.

Right-click on the project folder within momentics IDE and go down to "Build Configurations" and choose clean all.  This should clean the project and get rid of any previous launch configurations.  Now you just have to right-click ont he project folder again and go down to "Build Project" and press it.  Once the build is complete Right click the project again and go down to "Run as.." and select the simulator.  This should launch your application.

 

If this doesn't work then right click on the project and select delete, don't check the box asking to permanently delete the folder.  When it prompts whether you want to delete the launch configurations say yes.  It should now be gone from your momentics IDE.  Now right click in the folder pane in the momentics IDE and select import.  go under "genera" and select "existing projects into workspace".  Now click on browse and go to the folder that your momentics IDE saves and builds all the files.  it should be names something like "ndk-10.2-workspace" or something to that effect, then choose the folder of your project, click OK and finish.  Now you should try building your project and launching like I explained above.

Please use plain text.
New Developer
nelson0511
Posts: 23
Registered: ‎10-01-2013
My Device: devloper

Re: error message: You are trying to run an appliacation built for the device on the smulator.please rebuild your application for the simulator.

in the projects folder their is no "run as" so where would i find that?

 

what is the folder pane?

Please use plain text.