Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Trusted Contributor
pigling
Posts: 104
Registered: ‎02-05-2012
My Device: Bold 9900 (primary) Z10 LE (secondary)
Accepted Solution

fail to launch app on playbook

Hi,

I am trying to build a hello world C program in Native SDK for tablet OS. It succeeds to compile but fail to launch it on device. Everytime it copies the program to the device and then open it with a blank window. Then the window immediately close with an error on QNX Momentics IDE: "ldd:FATAL: Could not load library libbps.so.3". I have found libbps.so.3 on my PC folder which means the corresponding library missing on the device. How should I do to solve it? Google for nothing similiar issue.

Thanks.


PS, I installed Native SDK 2.0 on Windows XP and the OS version on playbook is 2.0.0.4869.

 

regards,

qichao

Developer
BGmot
Posts: 1,068
Registered: ‎11-24-2011
My Device: PlayBook

Re: fail to launch app on playbook

Do you have libbps.so in bar-descriptor.xml -> Assets?

BlackBerry Development Advisor
jhoffmann
Posts: 38
Registered: ‎10-26-2011
My Device: BlackBerry Bold 9900

Re: fail to launch app on playbook

You need to update the OS on PlayBook to a newer version.

BlackBerry Development Advisor
jhoffmann
Posts: 38
Registered: ‎10-26-2011
My Device: BlackBerry Bold 9900

Re: fail to launch app on playbook


BGmot wrote:

Do you have libbps.so in bar-descriptor.xml -> Assets?


This is only needed in NDK 1.  Do not add it if you are using NDK 2.

Trusted Contributor
pigling
Posts: 104
Registered: ‎02-05-2012
My Device: Bold 9900 (primary) Z10 LE (secondary)

Re: fail to launch app on playbook

Hi,

Thanks for your repsonse.

Is V2.0.0.4869 the latest Tablet OS for Playbook? I check the udpate and it says this is already latest version.

 

regards,

qichao

Trusted Contributor
pigling
Posts: 104
Registered: ‎02-05-2012
My Device: Bold 9900 (primary) Z10 LE (secondary)

Re: fail to launch app on playbook


jhoffmann wrote:

You need to update the OS on PlayBook to a newer version.


Thanks.

Just wait for 2.0.0.7111 update notification come in. 

New Contributor
gzhang
Posts: 3
Registered: ‎08-10-2011
My Device: 9800

Re: fail to launch app on playbook

Hi Anyone has update to fix this issue?

 

I tried it with Playbook version 2.0.0.6149 and NDK 2.0 -beta 3, got the exact same issue.

 

No idea how to figure it out.

 

~G

Trusted Contributor
pigling
Posts: 104
Registered: ‎02-05-2012
My Device: Bold 9900 (primary) Z10 LE (secondary)

Re: fail to launch app on playbook

Update to the latest 2.0.0.7111 will solve this issue.

Retired
fernando_simoes
Posts: 25
Registered: ‎01-30-2012
My Device: Bold 9900

Re: fail to launch app on playbook

You can quickly update your PlayBook OS to beta 2.0.0.7111 via https://bdsc.webapps.blackberry.com/native/beta/register

 

Please let us know if that fixed the issue. NDK 2 beta 3 is ironed out to work with OS 2.0.0.7111.