Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Contributor
Posts: 13
Registered: ‎02-19-2012
My Device: Blackberry simulator
Accepted Solution

glibc 2.4 error

Hi, i downloded the Native SDK 1.0 on Linux SuSe 9 and tried compiling my app. But when i start the compilation process the very first compilation line it throws the error:

qcc: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by qcc)

make: *** [/source/se/mgr.qnx.sh] Error 1

 

I am not sure what the error is.. i feel it is that qcc needs libc.so.6 whic inturn needs the glibc 2.4 to compile. I am unsure about how to go about this problem because i read at many other places that it is not genrally a good idea to install glibc 2.4. Can someone please help.

BlackBerry Development Advisor
Posts: 54
Registered: ‎10-26-2011
My Device: Playbook

Re: glibc 2.4 error

I don't think we support Suse.  

Please try the NDK on Ubuntu. 

Contributor
Posts: 13
Registered: ‎02-19-2012
My Device: Blackberry simulator

Re: glibc 2.4 error

thanks
Contributor
Posts: 13
Registered: ‎02-19-2012
My Device: Blackberry simulator

Re: glibc 2.4 error

So can you let me know which other flavours other than ubuntu are supported. Also if we update the glibc on suse to 2.4 will the SDK work?

BlackBerry Development Advisor
Posts: 54
Registered: ‎10-26-2011
My Device: Playbook

Re: glibc 2.4 error

As far as I know, we only verify against Ubuntu.