Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Contributor
somedeveloperguy
Posts: 34
Registered: ‎10-08-2012
My Device: developer
My Carrier: ??
Accepted Solution

i get the error: " No rule to make target `libcamapi.a' "

hey everyone,

 

i am trying to run an example app(see:https://github.com/blackberry/Cascades-Community-Samples/tree/master/NativeCamera) which is supposed to run on the playbook as wel.

but when building i found that there is a problem with the camera librerie.

 

i am using QNX Momentics IDE with OS version 2.1 and in the file common.mk i added the librerie in the following way: LIBS+= camapi

but while building i get the following error:"make[2]: *** No rule to make target `libcamapi.a', needed by `D:/BBaps/cameratest/arm/o.le-v7/cameratest'."

 

does anyone know why this happens?

and is there anyone who knows how to solve this problem?

Please use plain text.
BlackBerry Development Advisor
smcveigh
Posts: 660
Registered: ‎11-29-2011
My Device: developer
My Carrier: other

Re: i get the error: " No rule to make target `libcamapi.a' "

For some reason, on makefile builds (not managed builds), the make system tries to find .a's for all the libs that are required, even if we are linking against the .so version.  Since we do not ship a static libcamapi.a with the NDK, it gets angry.  This is omitted by design, so that when we release new software, your app doesn't need to be recompiled.

 

I thought this was supposed to be fixed in the latest 2.1 NDK release, in that there would be a dummy "libcamapi.a" file included, but maybe it didn't make it in for the last release.  I will check on that internally.  Are you using the latest 2.1 NDK?

 

In any event, just create an empty file named libcamapi.a either in your project path somewhere or in the ndk's install directory with the rest of the libs.

 

Cheers,

Sean

Please use plain text.
BlackBerry Development Advisor
smcveigh
Posts: 660
Registered: ‎11-29-2011
My Device: developer
My Carrier: other

Re: i get the error: " No rule to make target `libcamapi.a' "

I just checked the latest internal 2.1 NDK build and I can confirm the files are there:

 

./target/qnx6/armle-v7/usr/lib/libcamapi.a
./target/qnx6/armle-v7/usr/lib/libcamapi.so
./target/qnx6/armle-v7/usr/lib/libcamapi.so.1

 

Are you on the latest 2.1 NDK?  Are you building an ARM target, or a simulator?  There are no camera libs for the 2.1 simulator.

 

Cheers,

Sean

Please use plain text.
Contributor
somedeveloperguy
Posts: 34
Registered: ‎10-08-2012
My Device: developer
My Carrier: ??

Re: I get the error: " No rule to make target `libcamapi.a' "

I'm not sure if it is the latest one.

Where can I see that?

 

All I know is that I don't have the libcamapi.a file with the libraries.

I tried creating an empty file called libcamapi.a in the same folder as the other files but I still get the same error.

 

I will try downloading the latest version of the NDK to see if it works.

Please use plain text.
Contributor
somedeveloperguy
Posts: 34
Registered: ‎10-08-2012
My Device: developer
My Carrier: ??

Re: i get the error: " No rule to make target `libcamapi.a' "

i just downloaded the latset NDK from https://developer.blackberry.com/native/download/

but there is still no libcamapi.a file.

is the latest version you are talking about on some other location?

Please use plain text.
Contributor
somedeveloperguy
Posts: 34
Registered: ‎10-08-2012
My Device: developer
My Carrier: ??

Re: i get the error: " No rule to make target `libcamapi.a' "

for some reason i tried to compile for both simulator and device.
while i try to compile for device it works.

but i still don't know why the libcamapi file was missing

 

but thanks for your help.

Please use plain text.