Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
New Developer
Posts: 2
Registered: ‎09-18-2013
My Device: BB Bold 9800 - developer
Accepted Solution

"Could not connect to the internet" in Blackberry SDK (QNX Momentics IDE)

Hi there,

 

I'm looking into doing some blackberry development but I can't get the SDK to update.  I keep getting the message "Could not connect to the internet" on the canvas when I start the SDK

 

I checked my firewall settings and I manually added qde.exe in the exceptions but still no luck.  Has anyone ran into this before? I tried going into: Help -> Update API Levels and I get: "Unable to download SDK information".  When I checked the error log I noticed this message: java.net.ConnectException: Connection timed out: connect

 

My OS:

 

Windows 7 - Service Pack 1

8 GB Ram

New Developer
Posts: 2
Registered: ‎09-18-2013
My Device: BB Bold 9800 - developer

Re: "Could not connect to the internet" in Blackberry SDK (QNX Momentics IDE)

I had to enter the proxy info in the preferences tab (Window - Preferences, then General -> Network Connections).  After I restarted the SDK it worked!

New Developer
Posts: 3
Registered: ‎06-05-2014
My Device: z10

Re: "Could not connect to the internet" in Blackberry SDK (QNX Momentics IDE)

Did you enter proxy info for HTTP, HTTPS? What setting did you use for Active Provider (Manual, Direct, etc)? I'm not having any luck with it.
New Developer
Posts: 10
Registered: ‎11-06-2014
My Device: Anything running version 10

Re: "Could not connect to the internet" in Blackberry SDK (QNX Momentics IDE)

Bit late to the game but I've been fighting with thins since my company decided to lock the internet up for my own safety.

 

Active provider to manual.

 

Then I only set HTTP to the Host and Port provided by the guardians of the firewall (IT department) and that got me through our proxy to download the SDK and simulators.