Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
maminde
Posts: 73
Registered: ‎05-03-2011
My Device: 9550

strange suspend in debug cascade launch.

I write a program developed with C++ and QML, while I debug it, the screen show launch screen with dark blackberry and suspend here. There's not any error message, but the app's interface is not shown. How to solve this problem? I have tried slog2info to get some info below, seems no problem.

 

 


Sep 10 11:39:28.151 com.smartsoft.CurrencyRate.testDev_urrencyRate32c9dc59.7151626 default 9000 Qml debugging is enabled. Only use this in a safe environment!
Sep 10 11:40:22.170 com.smartsoft.CurrencyRate.testDev_urrencyRate32c9dc59.7151626 default 9000 OrientationSupportPrivate::getSupportedDisplayOrientation: portrait
Sep 10 11:40:22.170 com.smartsoft.CurrencyRate.testDev_urrencyRate32c9dc59.7151626 default 9000 OrientationSupportPrivate::initDirectionAndOrientation:
Sep 10 11:40:24.043 com.smartsoft.CurrencyRate.testDev_urrencyRate32c9dc59.7151626 default 9000 Unsupported query type: 100
Sep 10 11:40:24.061 com.smartsoft.CurrencyRate.testDev_urrencyRate32c9dc59.7151626 default 9000 Invalid URL:
Sep 10 11:40:24.082 com.smartsoft.CurrencyRate.testDev_urrencyRate32c9dc59.7151626 default 9000 QDeclarativeDebugServer: Waiting for connection on port 5768...

$

Author of pairs and Gradient
Please use plain text.
Developer
slashkyle
Posts: 820
Registered: ‎10-16-2012
My Device: Red Z10

Re: strange suspend in debug cascade launch.

it seems based on the code you provided that it is having issues connecting to a url

Sep 10 11:40:24.061 com.smartsoft.CurrencyRate.testDev_urrencyRate32c9dc59.7151626 default 9000 Invalid URL:

 you may want to try taking a look there and see whats up

Please use plain text.
New Developer
edybraun
Posts: 24
Registered: ‎09-11-2013
My Device: Z10, Dev Alpha C

Re: strange suspend in debug cascade launch.

Look at your code carefully. Duplicate id naming or a malformed url may be the problem. I had the same problem... the app built and deployed, and then would "hang" at the launch screen. In my case, the problem was that some objects had the same "id" name because I was copying some sections of code, I forgot to rename all the id's to different ones. The QNX IDE didn't pick up all the problems.

Please use plain text.
Developer
maminde
Posts: 73
Registered: ‎05-03-2011
My Device: 9550

Re: strange suspend in debug cascade launch.

thanks for reply quickly, I have found the problem, because I switch between 10.0 with 10.1 sdk, I should clean project first, then rebuild it. you can see the invalid url info is list before debug port listening, so this is not my application error.
Author of pairs and Gradient
Please use plain text.
Developer
maminde
Posts: 73
Registered: ‎05-03-2011
My Device: 9550

Re: strange suspend in debug cascade launch.

Thanks for reponse, I am lucky to solve it this morning.
Author of pairs and Gradient
Please use plain text.