Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Developer
jheron
Posts: 188
Registered: ‎01-27-2012
My Device: playbook

Re: ubuntu + QT5 + playbook (sans momentics and from command line)

Hi iravelo,

Qt5 is still only in beta (maybe only alpha?) stage, I would suggest that its not a great idea to encourage people to start deploying apps with it until it is released, or at the very least at release candidate stage. Otherwise there could be binary breaks with code created now and the final release of the Qt5 libs etc.

I would recommend sticking with Qt 4.8.1 until 5 is at RC stage. There are enough issues at the moment with 4.8.1 without having to introduce a beta version of Qt5.

With that being said, if your still interested in a QtQuick 2.0 example I can probably throw one together pretty quick as I dont believe there is any difference between 4.8 and 5 other than a couple of statements in the pro file...

Cheers,

Jon

 

Developer
iravelo
Posts: 61
Registered: ‎06-28-2011
My Device: 9700+PB

Re: ubuntu + QT5 + playbook (sans momentics and from command line)

[ Edited ]

Jon,

I did not realize Qt 5 is still in alpha state. 

Yes, it is too early to build and publish any software with it. I think i will stick to 4.8.x and focus on learning to optimaly build, debug and deploy with qt creator, and switch to qt creator 2.5 asap 

---------<={##}=>---------
I.Ravelo; Renault S.A.S. Corporate BBOS Java Apps Lead Conceptor/Coder; Qt learner
New Contributor
yyyy
Posts: 3
Registered: ‎06-17-2013
My Device: z10

Re: ubuntu + QT5 + playbook (sans momentics and from command line)

Several month have passed, Qt5.1RC already out, it would not be too long to see the release of Qt5.1.

Qt5 added a lot of modules, QtGraphicalEffects, QtQuick control, better support of opengl and so on.

So far so good, but we haven't heared any excited news about Qt5 + blackberry except of showing us

how to build the Qt5 by ourselves

 

As you know, many modules of Qt5 already support android development, there maybe some developers

would like to use Qt5 to develop android apps and BB10 apps without switching their Qt between 4 and 5

 

Do RIM has any plan to support Qt5?