Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Native Development

Reply
Contributor
cruzzmz
Posts: 31
Registered: ‎03-26-2013
My Device: Z10 Dev Edition
My Carrier: Celcom
Accepted Solution

webview url from listView sometimes return blank

Hi

I manged to do a webview url from xml data in a listView.

My question is in my xml, whenever i put a complete url like this:

<listItem title="Jln **bleep** Laut " 	weburl="http://www.itis.com.my/camera/DVR9/cam5.jpg"/> 

 the webview will return the page :smileyhappy:

 

BUT when i put the url as below:

<listItem title="Bukit Jalil" weburl="http://www.llm.gov.my/equip_cctv.aspx?highwayCode=KLP&equipCode=KLP_CAM_04_BUKIT_JALIL_SB"/>

 The listView become blank :smileysad:

 

i still cant figure out how to fix this could u help??

 

Please use plain text.
Developer
kamalakshan
Posts: 107
Registered: ‎06-12-2012
My Device: Dev Alpha C, Playbook
My Carrier: Loop

Re: webview url from listView sometimes return blank

You have mentioned in the post title that it sometimes returns blank, does it mean the same url works at times and at times it doesn't.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
Please use plain text.
Contributor
cruzzmz
Posts: 31
Registered: ‎03-26-2013
My Device: Z10 Dev Edition
My Carrier: Celcom

Re: webview url from listView sometimes return blank

Hi

it will return blank listView if whenever i put the 2nd link in my xml list :smileysad:

Please use plain text.
BlackBerry Development Advisor
sabdelsayed
Posts: 249
Registered: ‎08-17-2012
My Device: BlackBerry Z10 and Q10
My Carrier: Bell

Re: webview url from listView sometimes return blank

[ Edited ]

Hi cruzzmz, try replacing the "&" in the second URL with "&amp;".

 

 

 

 

@SamarAbdelsayed

Did this answer your question? Please accept post as solution.
Please refrain from posting new questions in solved threads.
Found a bug? Report it using the Issue Tracker
Please use plain text.
Contributor
cruzzmz
Posts: 31
Registered: ‎03-26-2013
My Device: Z10 Dev Edition
My Carrier: Celcom

Re: webview url from listView sometimes return blank

Solved my problem :smileyhappy:

 

Thanks

Please use plain text.
Developer
zezke
Posts: 1,004
Registered: ‎12-12-2010
My Device: Z10 (red Limited Edition)
My Carrier: Mobile Vikings

Re: webview url from listView sometimes return blank

Please mark this thread as solved, so I don't drop by for nothing.

-------------------------------------------
BlackBerry Certified Builder for Native Application Development -- Proud member of the Belgian BlackBerry Developer group
Samples: Park in Ghent
Feeling generous? Nominate me for BB Elite member!
Please use plain text.