Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Payment Service

Reply
New Developer
Posts: 41
Registered: ‎09-22-2009
My Device: Not Specified

How to enable blackberry.payment.developmentMode on the Blackberry 10 simulator?

Hello,

 

I am trying to setup the in app payment on a Blackberry 10 app. When I put the following line in my code, my app does not show any error but is not working anymore (buttons do not respond, etc.):

blackberry.payment.developmentMode = true;

What is the proper way to enable the payment development mode? I am doing all my tests on the Blackberry Simulator version 10.0.10.261. I do not have a real device.

 

Thank you for your help

Retired
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: How to enable blackberry.payment.developmentMode on the Blackberry 10 simulator?

That looks right. Do the buttons work without this line? What about with the value set to false?

 

Which WebWorks SDK did you use?

Garett
@garettBeuk
--
Goodbye everybody!
New Developer
Posts: 41
Registered: ‎09-22-2009
My Device: Not Specified

Re: How to enable blackberry.payment.developmentMode on the Blackberry 10 simulator?

Hi, 

 

Someone replied successfully to my post on StackOverflow.

 

http://stackoverflow.com/questions/15527709/how-to-enable-blackberry-payment-developmentmode-on-the-...

 

Best

Highlighted
Retired
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: How to enable blackberry.payment.developmentMode on the Blackberry 10 simulator?

Good 'ol Chad!

 

Thanks for referencing the solution Smiley Happy

Garett
@garettBeuk
--
Goodbye everybody!