Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Payment Service

Reply
New Contributor
vaclavmazany
Posts: 4
Registered: ‎11-24-2012
My Device: Developer
My Carrier: Developer
Accepted Solution

Live Testing Payment Service - Not receiving PURCHASE_RESPONSE after purchase

[ Edited ]

Currently I'm working on a game with in-app goods and I have read through the live testing "how to".

I've tried the example app and I have my app working with local connection :

paymentservice_set_connection_mode(true);

 All of my app logic works as expected.

 

The problem starts when I want to LIVE test, if this works.

When I LIVE test according to this Live Testing Tutorial

And I change connection_mode to :

paymentservice_set_connection_mode(false);

 

 

The purchase dialog appears, I fill in my password etc. Click PURCHASE and screen starts with the circle and that it is "processing", after a second or so, it fades out, but I don't receive any "succesful purchase" events.

 

I want to ask, if this is normal behavior with Sandbox & Live testing ? If so, is it so, that I MUST first release the App and in-app Goods before I can receive such events ? Or I'm doing something wrong ?

 

Testing with :

Playbook with OS 2.1.0.1526

BB DNK 2.1.0

 

Thx for any suggestions.


Any help appriciated.

Please use plain text.
BlackBerry Development Advisor (Retired)
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: Live Testing Payment Service - Not receiving PURCHASE_RESPONSE after purchase

Hi and welcome to the forums!

 

Which device are you using to test?

 

You should receive a response event, whether success or fail, regardless of how you are testing.

 

With Sandbox testing you need to have downloaded the app through BlackBerry World and also you must have Digital Goods added to the portal as well, have you done this?

Garett
@garettBeuk
--
Goodbye everybody!
Please use plain text.
New Contributor
vaclavmazany
Posts: 4
Registered: ‎11-24-2012
My Device: Developer
My Carrier: Developer

Re: Live Testing Payment Service - Not receiving PURCHASE_RESPONSE after purchase

Hi, thx for the answer.

In the meantime I was able to succesfully implement in-apps and test them in Sandbox Mode.

 

It was happening on Playbook.

I guess I had some glitch in my code, which was causing this.

Please use plain text.
BlackBerry Development Advisor (Retired)
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10
My Carrier: Bell

Re: Live Testing Payment Service - Not receiving PURCHASE_RESPONSE after purchase

Glad to hear! Thanks for following up

Garett
@garettBeuk
--
Goodbye everybody!
Please use plain text.