Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
Contributor
josempans
Posts: 14
Registered: ‎01-20-2013
My Device: Playbook

Belligerent Blocks issues

[ Edited ]

I was trying to compile Belligerent Blocks for playbook, and after trying a lot... I get an error that I can't figure how to solve.


"Entry-point asset is required in Configuration Default" || bar-descriptor.xml  || BlackBerry Tablet OS App Manifest Problem


I really don't know what is happening, here is the source of the bar file

 

   <configuration id="com.qnx.qcc.toolChain.2128392644" name="Default"> **Line with the error...
   <platformArchitecture>armle-v7</platformArchitecture>
   </configuration>

   <!-- Graphic resources -->
   <asset path="Assets/Background.png">Background.png</asset>
(... More assets)
   <asset path="Assets/splash.png">splash.png</asset>
    
    <!-- Sound resources -->
   <asset path="Assets/background.wav">background.wav</asset>
(... More sounds)
   <asset path="Assets/clickreverb.wav">clickreverb.wav</asset>
   
   <!-- High score database -->
   <asset path="Assets/scores.db">scores.db</asset>

 

What should I do?

 

Thanks in advance

 

Ok, I think that problem is solved... but I just can't compile... Box2D again is giving me errors... Box2D: No such file or directory. But I put the project Box2D on workspace, I built it, I put the references in Belligerent... and it can't found the lib... I'm very frustated... What can be the issue here?

Please use plain text.
Retired
whoang
Posts: 71
Registered: ‎11-08-2012
My Device: Blackberry 10 - Dev Alpha B | Blackberry Playbook | Blackberry Torch 9810

Re: Belligerent Blocks issues

[ Edited ]

Hello @josempans,

 

I understand the fustration with the integration points you described as I am able to reproduce the issue on my end as well.

 

Have you tried:

 

  1. Right Click on the Belligerent Blocks project within the IDE
  2. Build Configurations > Clean all 

 

Then try building the project:

  1. Right Click on the project
  2. Build Configurations> Build all or Build Project

 

There are some underlay mapping issues with the projects and files from an architecture standpoint and requires clean-up and re-building the project at times.

 

Curious where are you putting the Box2D folder within the Belligerent Blocks project?  

Do you mind providing the solution of your original problem that you solved?

 

Thank you, 

 

William Hoang

Application Developer Advocate | Developer Relations
BlackBerry


Please use plain text.