Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
Developer
kartoos
Posts: 27
Registered: ‎01-03-2013
My Device: Curve 8520
Accepted Solution

Blacbkerry 10 Simulator Deployment error in "Syncing and launching application"

I am using Momentics® IDE for BlackBerry Version: 2.0 Build id: v201310251603 with Simulator10.1.0.4828.

Momentics seems to connect and paired successfully to Simulator. When I click on "Run" , it starts the process of packaging and deployment but throws error in "Syncing and launching the application" part. There are different errors but no useful information in dialog box...here are two samples

 

 

Deployment Failed: Info: Failed to obtain QConn connection, sync disabled
Info: Sync not enabled, packaging full bar required for installation
Info: Sending request: INSTALL_AND_LAUNCH
Info: Action: Install and Launch
Info: Debug native: on
Info: File size: 304312
Info: Installing com.example.BB10TrackerSample.testDev_ackerSamplea7864132...
Info: Processing 304312 bytes

 

#2

 

Deployment Failed: Info: Attempt to use sync failed: Connection reset
Info: Sync not enabled, packaging full bar required for installation
Info: Sending request: INSTALL_AND_LAUNCH
Info: Action: Install and Launch
Info: Debug native: on
Info: File size: 304312
Info: Installing com.example.BB10TrackerSample.testDev_ackerSamplea7864132...
Info: Processing 304312 bytes

 

BlackBerry Development Advisor
MSohm
Posts: 14,757
Registered: ‎07-09-2008
My Device: BlackBerry Passport

Re: Blacbkerry 10 Simulator Deployment error in "Syncing and launching application"

Please refer to this article for details on this problem and a workaround.  Note that this issue is fixed in newer releases of BlackBerry 10.

 

Application Deployment may hang or fail after OTA Update to 10.1

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Developer
kartoos
Posts: 27
Registered: ‎01-03-2013
My Device: Curve 8520

Re: Blacbkerry 10 Simulator Deployment error in "Syncing and launching application"

Thanks for linking me to the right stuff

BlackBerry Development Advisor
MSohm
Posts: 14,757
Registered: ‎07-09-2008
My Device: BlackBerry Passport

Re: Blacbkerry 10 Simulator Deployment error in "Syncing and launching application"

No problem!  :smileyhappy:

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Visitor
sivachidhambaram
Posts: 1
Registered: ‎02-28-2013
My Device: Blackberry 10

Re: Blacbkerry 10 Simulator Deployment error in "Syncing and launching application"

Hi,

 

 

I m using the 10.2 SDK and 10_2_1.1925 simulator and vmware 5.0 with Windows 7 32bit OS. I having the same problem, someone help me plz.

 

 

 

Thanks

New Developer
bb72dev
Posts: 3
Registered: ‎08-15-2013
My Device: Playbook, Z10 LE, Dev Alpha C

Re: Blacbkerry 10 Simulator Deployment error in "Syncing and launching application"

Same Problem with VMware 6.0.1, Momentics IDE 2.0, 10.2.1 SDK, Win. 8.1 64bit

 

Thanks

Developer
kartoos
Posts: 27
Registered: ‎01-03-2013
My Device: Curve 8520

Re: Blacbkerry 10 Simulator Deployment error in "Syncing and launching application"

I am not sure but I read somewhere that it also happens on momentics if memory is below some threshold. Not sure though as I don't remember where I read