Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
Contributor
Posts: 20
Registered: ‎02-02-2013
My Device: None - developer using simulator
My Carrier: O2

Can't deploy BAR file to BlackBerry 10 Dev Alpha Simulator

Hi,

 

I'm trying to port my Android app to BB10 using the BB Android Runtime SDK.  I've packaged the app OK and created a BAR file, but cannot get it installed on the BB 10 Dev Alpha simulator.  I've tried both running the app from Eclipse using Run As->BlackBerry Android Launch, and using the BlackBerry Tablet OS Graphical Aid 'Install' option, and in both cases I get this output :

 

Info: Sending request: Install
Info: Action: Install
Info: File size: 1709216
Info: Installing ...
Info: Processing 1709216 bytes

 

In Eclipse I also get the error 'Failed to deploy project ...'.  In the BB graphical aid I just get the above output in the 'Operation Output' window.  Any ideas what the problem might be?

 

Thanks,

Jonathan

Contributor
Posts: 20
Registered: ‎02-02-2013
My Device: None - developer using simulator
My Carrier: O2

Re: Can't deploy BAR file to BlackBerry 10 Dev Alpha Simulator

Solved this by completely uninstalling VMPlayer and the BB10 simulator, cleaning my registry and then reinstalling. Still no idea why it wasn't working.

Contributor
Posts: 20
Registered: ‎02-02-2013
My Device: None - developer using simulator
My Carrier: O2

Re: Can't deploy BAR file to BlackBerry 10 Dev Alpha Simulator

Spoke too soon with my solution of re-installing, I once again have the problem of not being able to deploy my BAR files to my BB10 Dev Alpha simulator.  The deploy function always stops after the following output :

 

Info: Sending request: Install
Info: Action: Install
Info: File size: 200566
Info: Installing ...
Info: Processing 200566 bytes

 

I've tried using the Eclipse plugin, the graphical aid tool and various versions of the command line tools, but all have the same result that the app is not installed.


Any ideas?  Is there any other way to install the BAR file?

Jonathan

New Contributor
Posts: 8
Registered: ‎12-28-2012
My Device: Playbook
My Carrier: n/a

Re: Can't deploy BAR file to BlackBerry 10 Dev Alpha Simulator

I'm also having this problem. Clean install of Windows, latest VMWare Player and simulator.

Contributor
Posts: 14
Registered: ‎07-09-2011
My Device: PlayBook 16GB
My Carrier: N/A

Re: Can't deploy BAR file to BlackBerry 10 Dev Alpha Simulator

Same problem here. Config and app worked perfectly on the dev alpha, now that my dev alpha has been returned I'm trying to make modifications using the simulator.  Deploy fails after about 10 seconds at the "Processing:" line.  I've tried everything, no luck so far.

Contributor
Posts: 14
Registered: ‎07-09-2011
My Device: PlayBook 16GB
My Carrier: N/A

Re: Can't deploy BAR file to BlackBerry 10 Dev Alpha Simulator

Previous the simulator was running extremely slowly for me.  I followed this document <http://devblog.blackberry.com/2012/08/performance-increase-blackberry-10-simulator/> and enabled VT-x on my laptop, rebooted, and now the simulator runs orders of magnitude faster.  Also the deploy now uploads the app correctly every time.

 

So I think without CPU virtualization enabled, the simulator runs so slow that the deploy program simply times out.  Hope this helps.

New Contributor
Posts: 8
Registered: ‎12-28-2012
My Device: Playbook
My Carrier: n/a

Re: Can't deploy BAR file to BlackBerry 10 Dev Alpha Simulator

We'll I'm running BlackBerry 10 Simulator, in VMWarePlayer, in Windows, in VirtualBox VM, so that's probably my problem then.

Contributor
Posts: 20
Registered: ‎02-02-2013
My Device: None - developer using simulator
My Carrier: O2

Re: Can't deploy BAR file to BlackBerry 10 Dev Alpha Simulator

Hi, the virtualisation comments have no bearing on my problem - I have virtualisation enabled and my simulator performs well but I still can't deploy my BAR files.

 

For the record, my problems are on my Windows 7 64-bit laptop.  I have tried using the Mac OSX BB10 simulator and can successfully deploy my BAR file every time on that platform, but I have limited access to the Macbook and need to have it working on Windows.

 

Jonathan

Contributor
Posts: 14
Registered: ‎07-09-2011
My Device: PlayBook 16GB
My Carrier: N/A

Re: Can't deploy BAR file to BlackBerry 10 Dev Alpha Simulator

Jonathan, that's too bad this doesn't resolve your problem, it sounds like there is something else at play here, at least for you.  I am running Windows 8/64bit and can consistently make this problem come back or go away by toggling the virtualization setting and rebooting. The simulator is version 10.0.10.261, hosted in VMWare Player 5.0.1 with 6 GB of RAM on a ThinkPad with a Core2 Duo P8400 CPU - older hardware. With VT-x turned off the OS takes more than 8 minutes to boot up. When enabled it's on the home screen in less than a minute.

 

Interestingly I used to deploy to the PlayBook simulator on the same hardware without virtualization enabled and the experience was fairly quick decent and deploys always worked.

 

Thanks

Steve

 

New Contributor
Posts: 8
Registered: ‎12-28-2012
My Device: Playbook
My Carrier: n/a

Re: Can't deploy BAR file to BlackBerry 10 Dev Alpha Simulator

How do you run the simulator on Mac OS X? It told me to install VMWare Player, but there's no free version for Mac is there? Also, I have Java 7 installed and the simulator player insists on Java 6, which is stupid becuase 7 is entirely backward compatible.