Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
New Developer
kenonacid
Posts: 10
Registered: ‎11-23-2011
My Device: developer

Connect the BlackBerry Device Simulator to a BlackBerry Enterprise Server in 6.0

[ Edited ]

The procedure for connecting the Blackberry Device Simulator to a Blackberry Enterprise server is for version 4.0. Is there an updated procedure for the Blackberry Desktop Software version 6.0? My device simulator appears to be connected properly, however it never does a BES activation and it cannot send/receive email even though I have Outlook working with that account. The steps in the procedure show things that version 6.0 does not have. So is there an updated procedure. Or a place I can still download the 4.0 versions of the device manager and desktop manager? (They seem to be one package now.)

 

Moderator Note:  Moved to own topic and changed subject.

Retired
gbeukeboom
Posts: 2,559
Registered: ‎10-16-2009
My Device: BlackBerry Z10

Re: Connect the BlackBerry Device Simulator to a BlackBerry Enterprise Server in 6.0

Hi,

 

I will get the article updated shortly.

 

In the meantime I have tested that enterprise activation of a simulator definitely still works through the latest Desktop Software. To do this:

1) Launch the device simulator and BlackBerry Desktop Software

2) From the simulator menu bar select Simulate > USB Cable Connection

3) In Desktop Software the simulator should be found and a setup wizard may launch, if so, close the wizard

4) In Desktop Software select the "Device Options" button then the "Enterprise Email" tab

5) From this tab change "Email System" from "None" to whichever system you have configured, then choose the profile you wish to use from the subsequent pop-up

6) You will be asked to move your mouse to generate the encryption key just as you would a real device

 

Activation should commence after this is done, but it is not always automatic, it could take several minutes to intitiate the Enterprise Activation process. 

 

Regards,

Garett
@garettBeuk
--
Goodbye everybody!