Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
Developer
spoutnik
Posts: 39
Registered: ‎07-06-2012
My Device: DevAlpha, PlayBook

Re: Do not wipe Dev Alpha Update 10.0.9 Bundle 44

Hi,

Just wanted to add myself to the list :-( My DevAlpha is broken with similar symptoms: when I reboot the Desktop Manager proposes the repair. But then it gets stuck saying that it searches for updates. In the mean-time the device boots up to the menu with only the web browser in it. A long time later the Desktop Manager is saying  that it can not connect to device.

I tried pretty much everything mentioned in this post. Including reinstalling everything, removing drivers, trying 50 times .. but I can not get beyond that point. It is frustrating. I suppose that these devices are quite close to the final release. How will users rate an OS that breaks during a simple update process? And why does this work flawlessly on the PlayBook and not on BB10. I mean why did they not just use the same update process that was already working well?

I am out of ideas for now...

Contributor
fmbois
Posts: 16
Registered: ‎08-27-2011
My Device: Curve9300, PlayBook

Re: Do not wipe Dev Alpha Update 10.0.9 Bundle 44

"There are no BlackBerry Device Software updates available" if I use Desktop Software.

(http://supportforums.blackberry.com/t5/Testing-and-Deployment/How-to-Update-the-BlackBerry-10-Dev-Al...

 

"There was an error updating your software - There is no update available" if I follow RIM's official procedure with WipeReload.bat

(https://developer.blackberry.com/blackberry10devalphas/update my windows XP registry has none of the SLSURL and WebSLURL keys)

 

Whereas most people have their update interrupted in the middle of the process, I cannot even start the update. It let me feel either the Update Server is down or my Dev Alpha is not registered in the server's database.

 

Update should be plain simple by following the official procedure (the 2nd link above), it should not require the acrobatics experienced in so many threads. Updating a embeded device is a simple and common practice today without much technical difficulty: load the new code into flash/ROM then send a message to swac. However I tried them all in the hope of a success, but in vain.

 

Can someone from RIM give an explaination please? It may save much time to your developers. Is it possible to provide developers with a standalone package that we can run on PC that feeds the update directly into our Dev Alpha? That would solve most of the update failure and avoid broken Dev Alpha that we see in various threads in this Forum. Without Dev Alpha in 10.0.9.388, we are stuck because, seeking a minimum of quality, we are not supposed to submit applications without testign them on a real device close to BB10.

 

Thanks

 

(Trying to upgrade my Dev Alpha from original 10.0.4 to 10.0.9.388)

 

Contributor
apersaud500
Posts: 41
Registered: ‎03-26-2011
My Device: 8520, 9300, Playbook, Dev Alpha

Re: Do not wipe Dev Alpha Update 10.0.9 Bundle 44

i did everything, everything that rim had said, and everything that is in this forum. i give up. If you do listen to the usb connection sounds as the device tries to updates it triggers seversal times. This might be the cause of the problem. i think it loses connection to the device.

First day after receiving a BB 10 Dev Alpha B i did a security wipe and was able to reinstall the os without any hassle Loader.exe was able to grab the OS, even though there was no update; just the same version. 

 

I dont know what can help but saw few persons getting through, as for the rest i guess we have to keep trying.... :Wacko:

Contributor
bobbydriscol
Posts: 23
Registered: ‎05-04-2012
My Device: Playbook, 9670, 9800, 9350

Re: Do not wipe Dev Alpha Update 10.0.9 Bundle 44

Sounds like the device is bricked (wiped after upgrade or something along those lines).

Steps if you've bricked your Dev Alpha (only have web browser) or the device is only flashing on startup of the device and nothing else.



Launch WipeReload.bat

Make sure your mouse is over the disabled button to update on your computer
With your Dev Alpha plugged in, restart the device (hold power button for 10 seconds after the countdown shows)
When the dev alpha red led lights up, you have a split second to click that button in the WipeReload.bat application instance. If you miss it you'll need to wait until the dev alpha starts up and try again.
Update the device


In wipereload it will only see the device for a split second -- if your timing is off you'll miss it. Why it doesn't see an update is that your device has the current OS but the OS is damaged in some way. Mine did this because I had a short password (3 chrs) which is not possible in the new version of the OS.
Contributor
apersaud500
Posts: 41
Registered: ‎03-26-2011
My Device: 8520, 9300, Playbook, Dev Alpha

Re: Do not wipe Dev Alpha Update 10.0.9 Bundle 44

did that and it keeps saying no update available
Contributor
AwesomeDev
Posts: 39
Registered: ‎04-23-2011
My Device: N/A

Re: Do not wipe Dev Alpha Update 10.0.9 Bundle 44

Same issue as fmbois . PLEASE HELP!

Contributor
apersaud500
Posts: 41
Registered: ‎03-26-2011
My Device: 8520, 9300, Playbook, Dev Alpha

Re: Do not wipe Dev Alpha Update 10.0.9 Bundle 44

what also happens is that the device just starts up while trying to search for the update. i guess it just exists bootloader mode or something. i am not sure.
Contributor
bobbydriscol
Posts: 23
Registered: ‎05-04-2012
My Device: Playbook, 9670, 9800, 9350

Re: Do not wipe Dev Alpha Update 10.0.9 Bundle 44

You can only get it to update at the bootloader point -- after that it will lose connection to the computer and the wipeloader won't recognize the device.

You can try working with btsbetasupport@rim.com as well if none of these steps work (but it worked for me).
Contributor
apersaud500
Posts: 41
Registered: ‎03-26-2011
My Device: 8520, 9300, Playbook, Dev Alpha

Re: Do not wipe Dev Alpha Update 10.0.9 Bundle 44

The furtherest i am getting is "There is no update available"....
Contributor
fmbois
Posts: 16
Registered: ‎08-27-2011
My Device: Curve9300, PlayBook

Re: Do not wipe Dev Alpha Update 10.0.9 Bundle 44

After trying and retrying one night and a morning and being pretty sure I cannot make it, I finally turn to RIM for help sending a email to btsbetasupport@rim.com

I will post their answer. Following is the essential content of my email:

 

subject: cannot update my Dev Alpha from the original load (10.0.4.197) to the latest 10.0.9.3.88)‏


The OS version :
=============
10.0.4.197

 

An overview of the issue you experienced:
========================================
cannot update my Dev Alpha from the original load (10.0.4.197) to the latest 10.0.9.3.88), it always ends up with:
"! There was an error updating your software" next line: "There is no update available".
This is the first time I try to update my Dev Alpha.
(http://208.74.204.192/t5/Testing-and-Deployment/Do-not-wipe-Dev-Alpha-Update-10-0-9-Bundle-44/td-p/1...

 

Suggestions:
==========
1) If it requires a check on Dev Alpha device ID, would you please check whether my phone 29D9110D is in your server database
2) If the latest bootloader in update 10.0.9.3.88 is no longer compatible with the original OS 10.0.4.197, would you please give me the links to intermediate loads so I can update by steps of load version? I cannot reach the old updates any more (10.0.6, 10.0.9.44)

 

Steps used to reproduce the issue
=================================
Altenative 1 (https://developer.blackberry.com/blackberry10devalphas/update)
1.1) using my dev PC XP which has all the SDKs, Desktop Software, keys etc except the latest SDK beta 3
1.2) install the latest Desktop Software 710_b033_multilanguage.exe
1.3) download App_Loader_7.1.0.34.zip, unpack, run AppLoaderWebSL_7.1.0.34.msi to install.
1.4) restarted the PC several times
1.5) There are no SLSURL and WebSLURL keys in my windows XP register and there have never been.
1.6) Dev Alpha in working state (Browser and Settings icons on its screen). It can be booted into the normal mode by long pressing power button to avoid "Thank you..Dev Alpha..has ended"
1.7) Run WipeReload.bat, see the window titled "Device Connection" containing a form "Select a device to connect: PIN: [ ]", with "OK" button greyed out and "Cancel buttun" enabled.
1.8) Connect the already started Dev Alpha (as said in 1.6) to my PC windows XP via USB.
See in Windows XP Icons Tray a pop-up from BlackBerry Device Manager saying "BlackBerry (29D9110D) has been connected to system initializing device access"
and at the same time in WipeReload.bat window "OK" becomes enabled, PIN filled: BlackBerry (29D9110D)
1.9) click OK button in WipeReload.bat window. See a new WipeReload window "Please wait while ..software is updated",
Then WipeReload.bat goes through successif steps as follows:
- "Connecting boot ROM" in WipeReload window
- Dev Alpha screen goes off, apparently the device goes into bootloader mode, a good sign for me
- "Uploading RAM image" in WipeReload window
- "read device system configuration" in WipeReload window
- WipeReload pops up a dialog window "! There was an error updating your software", "There is no update available"
- click OK in the new WipeReload window. WipeReload exits by itself
- Dev Alpha restarts it self only after I click the OK button to make WipeReload exit as above. Apparently WipeReload locks the device when it is still running, a good sign for me.
This time Dev Alpha boots into "Thank you..Dev Alpha..has ended".

Altenative 2 (http://208.74.204.192/t5/Native-Development/BB10-dev-alpha-device-not-started/td-p/1890659)
all steps and results are similar to Alternative 1 except:
2.8) Connect my Dev Alpha via USB regardless it's working or switched off or in "Thank..Dev Alpha..has ended".
Long press the power button util the red LED flashes and it appears in WipeReload window: PIN: BlackBerry (Unknown)
2.9) click on OK button immediately for Dev Alpha to stay in bootloader mode (well, I think).

Alternative 3: try to update the BlackBerry 10 Dev Alpha Device Software through Desktop software
(http://supportforums.blackberry.com/t5/Testing-and-Deployment/How-to-Update-the-BlackBerry-10-Dev-Al...
same error with slightly different wording:
There was an error updating your software", "There are no BlackBerry Device Software updates available"


Reproducibility of the issue:
============================
constant and by many people (http://208.74.204.192/t5/Testing-and-Deployment/Do-not-wipe-Dev-Alpha-Update-10-0-9-Bundle-44/td-p/1...