Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
New Contributor
meiko
Posts: 2
Registered: ‎08-20-2010
My Device: Not Specified
Accepted Solution

Error when receiving E-Mail in Simulator/MDS

[ Edited ]

Hi

 

I configured the MDS from the eclipse plugin to work in email-standalone mode.

(Email.mode=standalone)

Starting mds and then the simulator...

If i send an email to mds (by using outlook express smtp:localhost),i got following output in the mds-consol:

 

<2010-08-20 15:35:12.362 MESZ>:[56]:<MDS-CS_MDS>:<DEBUG>:<LAYER = CMIME, SMTPServer::Received command: MAIL FROM: <TEST@SIM.DE>>
<2010-08-20 15:35:12.372 MESZ>:[57]:<MDS-CS_MDS>:<DEBUG>:<LAYER = CMIME, SMTPServer::Received command: RCPT TO: <TEST@TEST.DE>>
<2010-08-20 15:35:12.372 MESZ>:[58]:<MDS-CS_MDS>:<DEBUG>:<LAYER = CMIME, SMTPServer::Received command: DATA>
<2010-08-20 15:35:12.483 MESZ>:[59]:<MDS-CS_MDS>:<DEBUG>:<LAYER = SCM, EVENT = Refresh device storage:6>
<2010-08-20 15:35:12.483 MESZ>:[60]:<MDS-CS_MDS>:<DEBUG>:<LAYER = SCM, EVENT = Refresh device storage end; time:0>
<2010-08-20 15:35:12.493 MESZ>:[61]:<MDS-CS_MDS>:<DEBUG>:<LAYER = CMIME, Sending to device pin: 2100000A>
<2010-08-20 15:35:12.563 MESZ>:[62]:<MDS-CS_MDS>:<DEBUG>:<LAYER = CMIME, Queued: 2100000A>
<2010-08-20 15:35:12.563 MESZ>:[63]:<MDS-CS_MDS>:<DEBUG>:<LAYER = CMIME, SMTPServer::Received command: QUIT>
<2010-08-20 15:35:12.603 MESZ>:[64]:<MDS-CS_MDS>:<WARNG>:<LAYER = SCM, EVENT = Cannot load GME compression library>

The simulator displays:

JVM Error 104

Uncaught: EOFException

 

I got this Stacktrace when starting the simulator in debugging mode:

 

Thread [net_rim_services_impl(3)id=205152256] (Suspended (exception EOFException))    
    GMEDatagram(DataBuffer).readByte() line: 650    
    GMEDatagram(DataBuffer).readCompressedInt() line: 1117    
    CMIMEParameters(Parameters).read(byte) line: 133    
    CMIMEParameters(Parameters).read(DataBuffer, byte) line: 99    
    RIMMessagingIncomingMessage.read(DataBuffer) line: 187    
    RIMMessagingService.receivePacket(DataBuffer, Object) line: 283    
    DefaultReceiveThread.run() line: 206   

 

I got the same problem with the MDS-version from the installer "BlackBerry_Email_MDS_4.1.4.exe". With ESS the receiving of emails is working. But the use of ESS is not an option for me, because my app is using email and soap to communicate with a web-application. So i need both - the mds features AND the possibility to receive emails. I tried to use MDS and ESS side by side, but this leads to other problems.

 

Environment:

- Windows XP

- JDK 1.6.0_21

- Eclipse JEE 3.5

- Blackberry Eclipse Plugin (tested 4.7.0.57 and 5.0.0.25)

- Outlook Express to send the emails (smtp: localhost)

 

thank for your help

 

Meiko

Please use plain text.
Administrator
MSohm
Posts: 14,410
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Error when receiving E-Mail in Simulator/MDS

What is the language setting in Windows XP?  I have seen similar issues when it is set to something other than English and/or if there are "special" characters in the email message being sent.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
New Contributor
meiko
Posts: 2
Registered: ‎08-20-2010
My Device: Not Specified

Re: Error when receiving E-Mail in Simulator/MDS

Thank you. That was the problem.

I changed my language settings (http://dev.ektron.com/kb_article.aspx?id=5982) and it works now.

Please use plain text.
Contributor
pinturic
Posts: 28
Registered: ‎07-15-2010
My Device: Not Specified

Re: Error when receiving E-Mail in Simulator/MDS

Hi all

 

I am having the same problem but after changing the settings and rebooting nothing changes. Is there any other change to make ?

Please use plain text.
New Contributor
mvoit
Posts: 4
Registered: ‎05-31-2011
My Device: Simulator 9800
My Carrier: Simulator

Re: Error when receiving E-Mail in Simulator/MDS

Hi!

 

I am having the same problem, but changing the Windows language setting to English (US) did not help.

 

Simulator:

JVM Error 104

Uncaught: EOFException



Stacktrace in debugger:

Thread [net_rim_io_impl(102)id=290325504] (Suspended (exception EOFException))   
    GMEDatagram(DataBuffer).readByte() line: 661   
    GMEDatagram(DataBuffer).readCompressedInt() line: 1177   
    CMIMEParameters(Parameters).read(byte) line: 135   
    CMIMEParameters(Parameters).read(DataBuffer, byte) line: 101   
    RIMMessagingIncomingMessage.read(DataBuffer) line: 189   
    RIMMessagingService.receivePacket(DataBuffer, Object) line: 289   
    DefaultReceiveThread.run() line: 210

 

Environment:

- Windows 7 (64-bit)

- Java(TM) SE Runtime Environment (build 1.6.0_21-b07)

- BlackBerry Java Plug-in for Eclipse 1.3.0

 

 

Any help appreciated!

 

Mark

Please use plain text.
New Contributor
mvoit
Posts: 4
Registered: ‎05-31-2011
My Device: Simulator 9800
My Carrier: Simulator

Re: Error when receiving E-Mail in Simulator/MDS

Ok, finally got it solved.

 

Under 'Region and Language' settings in Control Panel,

I also had to change the date format

Formats -> Format -> English (United States)

 

Previously I had only changed

Admistrative -> Change system locale... -> English (United States)

 

I also changed 'Location' to 'United States',

but already reverted it and BBM/MSD still seems to work (no reboot, though).

 

'Keyboards and Languages' I left as it was.

Which is set to 'Finnish (Finland)' in my case.

 

Pretty crappy bug I'd say.

Hopefully this is solved in BBM 6.0.

 

 

Mark

 

Please use plain text.
Contributor
areveillon
Posts: 16
Registered: ‎05-11-2010
My Device: 8900
My Carrier: Orange

Re: Error when receiving E-Mail in Simulator/MDS

Hi,

 

I have exactly the same problem. Are you sure we need to change our language settings to develop with BBM SDK ??? That's really really strange !

 

I tried to change all languages settingsbut I still have this "App Error 104"?

 

Can some one from RIM give us more details about this error ?

 

Thank you in advance,

Antoine

Please use plain text.
Administrator
MSohm
Posts: 14,410
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Error when receiving E-Mail in Simulator/MDS

This sounds like a different error.  I recommend posting the full error, where you see it and steps that triggered it in a new thread.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.