Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
New Contributor
Tworas
Posts: 3
Registered: ‎09-03-2012
My Device: BlackBerry 9900

Momentics IDE+ Dev 10 Alpha - slow launch application

[ Edited ]

Hi,

I can not find any information anywhere about my problem.

I run the application in Momentics IDE and simulator Dev 10.

 

When I click "Run" and in the window "Progress" display me two messages:

 

 

It takes more than 3 minutes - every time when I want to run the application.

 

Why?
How to speed up applications to run on the simulator?

BlackBerry Development Advisor
MSohm
Posts: 14,753
Registered: ‎07-09-2008
My Device: BlackBerry Passport

Re: Momentics IDE+ Dev 10 Alpha - slow launch application

There are a couple things to check.  First off, make sure you have enabled CPU virtualization to ensure you are getting the best performance out of the simulator.  This blog post has more info on the topic:  Would you like a 1130% Performance Increase for your BlackBerry 10 Simulator?

 

Also, if you have a large application make sure you are only deploying the files that have changed.  You can modify this in the Run/Debug As Configuration.  Click on the upload tab and ensure the optiont to only upload files that have changed is checked.  Here is a screenshot of that option.

 

upload.png

 

 

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Contributor
Tworas
Posts: 3
Registered: ‎09-03-2012
My Device: BlackBerry 9900

Re: Momentics IDE+ Dev 10 Alpha - slow launch application

Thank you for your reply,

 

My problem solved in other ways.
I set the network adapter to "only-host" in the VMware then I set the correct ip addresses in Momentics IDE.
Now run the application takes about 4 seconds.

New Developer
Stephen_Hard
Posts: 10
Registered: ‎12-05-2012
My Device: Playbook, Dev Alpha B

Re: Momentics IDE+ Dev 10 Alpha - slow launch application

[ Edited ]

That's not really enough info to help other travellers. Especially since you had an issue following my more explicit instructions yourself.

 

Tworas escaped the problem by followed the instructions in the new Slow deploy/download/install to Simulator *SOLUTION* thread. Also posted his subsequent difficulty there. Putting in a link would have helped others to find it, y'know.

 

When people talk about + 3 minuite delays with deployment, they are usually suffering from this specific bug, so need to be directed to a specific fix.

 

Stephen Hard