Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
Regular Contributor
IpiRon
Posts: 75
Registered: ‎10-19-2011
My Device: Developer
My Carrier: verizon
Accepted Solution

Status of Audio in Simulators?

Newbie again, I am currently developing a simple Java app targeting JRE 5.0 and above using the Eclipse Plugin 1.5.2. I have the necessary logic to play a simple MP3 file and the code steps through fine on my 9330 simulator but I don't actually hear anything from the speakers on my development machine. I've done 'SEARCH'ing and see that over time a lot of people indicate problems with certain simulators and playing audio. How do I go about determining the status of playing audio on various simulators at this point? I'm looking for something that indicates exactly needs to be in-place so that audio will work on the simulators and/or a list of simulator models that work/fail. I do not want to waste time trying to decide if it is a simulator problem or that I don't have something properly setup in my development environment.

 

As part of my searching, I ran into this: https://developer.blackberry.com/devzone/resources/#simulator. I had never seen this before. Is this targeting the simulators for the 10 series only or will it work for all other simulators? I'm not using any type of VM (didn't see it required in any other documentation).

 

I'm going to keep on searching but if anyone can point me in the proper direction it would be greatly appreciated. Thanks in advance!

Please use plain text.
Administrator
MSohm
Posts: 14,314
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Status of Audio in Simulators?

The link you refer to is for BlackBerry 10 and BlackBerry PlayBook simulators.

 

The 7.1 and lower BlackBerry smartphone simulators make use of the audio codecs installed on your PC for audio playback.  Are you saying that you hear audio from some simulators but not others?  Or are you not hearing audio from any of them?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
Regular Contributor
IpiRon
Posts: 75
Registered: ‎10-19-2011
My Device: Developer
My Carrier: verizon

Re: Status of Audio in Simulators?

Mark,

 

I played with this over the weekend and did get it to work. I did a clean.bat on the simulator and made some coding changes and it all worked. I'm chaulking it up to 'newbie'. I did find the 'getResourceAsStream' a bit confusing. I am currently only using the 9330 and 8530 simulators.

 

When 'SEARCH'ing on this topic, there are some posts indicating 'issues' with simulators. I try to take all posts with a grain of salt since they can be stale and/or resolved, I wonder if there is a place where any issues with simulators are listed and if there are resolutions/work arounds? I'll mark this closed since I am proceeding.

 

Thanks for the reply!

Please use plain text.
Administrator
MSohm
Posts: 14,314
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Status of Audio in Simulators?

Known Issues with the simulators at the time of release are listed in the release notes found here:  BlackBerry Smartphone Simulator Docs

 

Problems logged by third party developers can be found in Issue Tracker.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.