Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
New Contributor
alterecho
Posts: 2
Registered: ‎05-02-2014
My Device: Z10
My Carrier: UNLOCKED
Accepted Solution

Unable to deploy to device/emulator for debugging

Hi,

I'm trying to deploy a simple program, to the device, for learning Cascades, but its stuck at "(BLOCKED: user operation is waiting for "" to complete)"

This is ridiculous. I've tried a lot of things like re-installing the Momentics IDE, toggling the development mode on the device, etc.

 

http://tinypic.com/m/i6ccbc/4

 

Any ideas anyone?

Please use plain text.
Administrator
MSohm
Posts: 14,314
Registered: ‎07-09-2008
My Device: BlackBerry Z30, BlackBerry PlayBook
My Carrier: Bell

Re: Unable to deploy to device/emulator for debugging

Is Momentics able to connect to the simulator?  To verify, right click on the simulator device in your project view and choose BlackBerry Tools -> Connect.  Does it have any issues connecting?

 

Do you have any local firewall software running that could be blocking the connection?

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Please use plain text.
New Contributor
alterecho
Posts: 2
Registered: ‎05-02-2014
My Device: Z10
My Carrier: UNLOCKED

Re: Unable to deploy to device/emulator for debugging

It seems to work now. It still happens sometimes though. I DO have firewall and anti-virus, but that doesn't seem to be the cause for the random hold ups.

Thanks

Please use plain text.