Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
Regular Contributor
DHulka
Posts: 53
Registered: ‎06-25-2012
My Carrier: Rogers
Accepted Solution

Upgrading from 10.0.6.386 to 10.0.9

I hadn't used the Dev device in a couple of weeks so I was still on the build that every other time you'd reboot it would say "Thank you for Partipating"

The problem now is that I'm following the instructions but the Wipe Device batch script reboots the device and it goes into "Thank you for Partipating"

 

I can't seem to get around this. Maybe if I could find the last update I'd be able to do it.

Please use plain text.
Contributor
theninjew
Posts: 19
Registered: ‎07-19-2012
My Carrier: Sprint

Re: Upgrading from 10.0.6.386 to 10.0.9

Im on the same version and loader doesnt seem to recognize an update

Please use plain text.
Developer
MauriceRice
Posts: 423
Registered: ‎03-17-2011
My Carrier: Telus

Re: Upgrading from 10.0.6.386 to 10.0.9

Some suggestions:

 

1. Download and install app loader from here:

https://developer.blackberry.com/blackberry10devalphas/update

2. Restart your dev alpha device by holding down the on/off button for 10 seconds. Red light will go on and device will reboot without the "end of participation" notice.

3. When the device has rebotted fully, cennect it to your PC via USB and then execute install process indicate at the URL noted in point #1

_________________________
In the dark and need a sky map?
Discover What's up at App World.
Follow What's up on Facebook

Please use plain text.
Contributor
theninjew
Posts: 19
Registered: ‎07-19-2012
My Carrier: Sprint

Re: Upgrading from 10.0.6.386 to 10.0.9

Thanks for that. My device has trouble finding an update after loading the wiperestore.bat file. I want to mention that BlackBerry Device Manager comes up every time I connect the device to the pc and I think it interupts the process. Tried un-installing it and then rebooting the pc but it "magically" comes back. I tried ending the process before I hit "OK" to start the update process, but it doesn't recognize an update and the device reboots. I've tried this method numerous times.
Please use plain text.
Regular Contributor
DHulka
Posts: 53
Registered: ‎06-25-2012
My Carrier: Rogers

Re: Upgrading from 10.0.6.386 to 10.0.9

[ Edited ]

I've done this a number of times. As soon as the WipeReload script is run it reboots the device back to the "Thank you for Partipating" screen

Please use plain text.
Contributor
theninjew
Posts: 19
Registered: ‎07-19-2012
My Carrier: Sprint

Re: Upgrading from 10.0.6.386 to 10.0.9

I wonder if you need to be on the latest OS in order to update to this one. Hmm.....
Please use plain text.
Developer
MauriceRice
Posts: 423
Registered: ‎03-17-2011
My Carrier: Telus

Re: Upgrading from 10.0.6.386 to 10.0.9

You should not uninstall desktop software. You need to reinstall DS and also you should use the App Loader .bat file  (not DS) to intall the update.

 

I have tow XP computers. For some reason on one of them, the dev alpha's PIN is not recognised and the install does not work and I have not figured out a work-around. On the other PC, the PIN is recognized and the installation proceeds to completion.

 

In the later case, the Dsktop Software displayed its update dialog and I just ignored it as it did not affect the installation. If you really want to avoid the annoying DS dialog, you can try turning off auto-start by going to to Tools/Destop Options... Then unselect "Start Blackberry Desktop Software when device is connected".

_________________________
In the dark and need a sky map?
Discover What's up at App World.
Follow What's up on Facebook

Please use plain text.
Developer
MauriceRice
Posts: 423
Registered: ‎03-17-2011
My Carrier: Telus

Re: Upgrading from 10.0.6.386 to 10.0.9


theninjew wrote:
I wonder if you need to be on the latest OS in order to update to this one. Hmm.....

The device does not have to be in the "off" state when using the .bat App loader. If you leave it on and then connect via USB, it will not reboot into the "thanks for participating" mode.

_________________________
In the dark and need a sky map?
Discover What's up at App World.
Follow What's up on Facebook

Please use plain text.
Contributor
theninjew
Posts: 19
Registered: ‎07-19-2012
My Carrier: Sprint

Re: Upgrading from 10.0.6.386 to 10.0.9

Maybe un-installing everything and starting will work.
Please use plain text.
Developer
MauriceRice
Posts: 423
Registered: ‎03-17-2011
My Carrier: Telus

Re: Upgrading from 10.0.6.386 to 10.0.9

[ Edited ]

theninjew wrote:
Maybe un-installing everything and starting will work.

I don't quite follow. What are you wanting to uninstall? DS should be installed so that the required USB drivers are available.

 

My suggestiion:

1. Get a fresh start by uninstalling both DS and the App Loader using control pannel "Add remove software". Reboot your PC.

2. Reinstall DS and shut it down. Then install the App Loader using the i.msi file downloaded  from https://developer.blackberry.com/blackberry10devalphas/update

3. Start your dev alpha in it's normal state. (i.e. no thanks for participating" nonsense. Press and hold the power button to reboot, if necessary.

4. With dev alpha on, start the App Loader bat file. Do not be concerned it DS starts and displays its debrick dialog. Ignore it.

_________________________
In the dark and need a sky map?
Discover What's up at App World.
Follow What's up on Facebook

Please use plain text.