Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Testing and Deployment

Reply
New Contributor
Posts: 7
Registered: ‎02-19-2012
My Device: Rim Playbook
My Carrier: Roger

error Authentication failed due to invalid password -cannot launch to simulator

A few days back, I posted this in the web dev forum. I am reposting it here because this seems to be the right forum to get help on my problem.

 

I have

VMPlayer 4.0.2 build-591240

BlackBerryPlayBookSimulator-1.0.7

Adobe AIR 3.1 SDK

Ripple Build & Deploy (v0.9.0)  Ripple Framework (v0.9.1)

Windows 7


I created .bar using both Ripple and SDK and tried to launch using both Ripple and SDK, but always getting the error Authentication failed due to invalid password -cannot launch to simulator , in case of SDK. Ripple log does not show the error.

I have tried reinstall SDK. Tried changing password on the simulator but the screen locks if I put password as ON.

I have not reinstalled AIR sdk yet.

 

My initial problem with compile went away after I made sure that the 32 bit java was being used.

The following shows my Deploy command.

 

C:\Program Files (x86)\Research In Motion\BlackBerry WebWorks SDK for TabletOS 2
.2.0.5\bbwp\blackberry-tablet-sdk\bin>blackberry-deploy.bat  -installApp -passwo
rd playbook -device 192.168.111.128 -package c:\sketchpad.bar

I saw some old postings for this error, anyone is having this problem with the new SDK?

I also noted that I did not get any prompt to enter password when installing the simulator.

 

Update: Although launch or deploy to the simulator is still a problem for me, I managed to launch it to the actual tablet using debug token.

I followed the following steps with success.

Refer to RIM reference documentation for details of each step. The idea here is to show the sequence of steps and some pitfalls to avoid.

 

1. Try launch to simulator ( not working yet). One can continue testing as below using a real tablet.

 

2a to 2c are done one time only and steps 2d and 2e are repeated as needed.

 

2a. Register or setup PC to sign application - blackberry-signer -register etc etc. Please note that the storepass is a new password you come up with and is different from PIN you sent to RIM, which is for identification and is exposed.

 

2b.create debug token-blackberry-debugtoken request etc etc . Please note that you can get Tablet information like PIN or IP address from the tablet menu About and then choosing drop down options hardware, network etc.

I had file access issue if I put the debugtoken.bar in root directory C:\, I had to change it to a subdirectory like c:\rim.

 

2c.Deploy the debug token and receive into the Tablet-blackberry-deploy -installDebugToken etc etc and in parallel go to Tablet menue security/development mode/upload debug token.

 

2d. Build application with debug token-bbwp xxx.zip -d -o etc

2e.deploy to tablet-blackberry-deploy etc etc.

 

Hope this will help some one else to deploy to the Tablet and will give me more time to figure out why I cannot deploy to simulator.

 

BlackBerry Development Advisor
Posts: 15,207
Registered: ‎07-09-2008
My Device: BlackBerry Passport
My Carrier: Bell

Re: error Authentication failed due to invalid password -cannot launch to simulator

The BlackBerry PlayBook simulator no longer requires a password.  Try to deploy without the -password parameter.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Contributor
Posts: 7
Registered: ‎02-19-2012
My Device: Rim Playbook
My Carrier: Roger

Re: error Authentication failed due to invalid password -cannot launch to simulator

Since the suggested method did not solve the

Error: Authentication failed due to invalid password
I re-installed everything and noticed that the simulator is more robust ie responds to various buttons and i also corrected the time to match windows 7 time, but I still get error

Error: Authentication failed due to invalid password
when I try to launch an App like kitchen sink. I can deploy ok to the real tablet using debug token.

Highlighted
New Contributor
Posts: 7
Registered: ‎02-19-2012
My Device: Rim Playbook
My Carrier: Roger

Re: error Authentication failed due to invalid password -cannot launch to simulator

After trying a number of combinations the following worked for me ie I do not get the Authentication failure message.

VMware 3.15 and Simulator 1.08. I got the idea of trying different combinations after reading other related posts. I wish we could look into a log or something to see why it was complaining about password. Is it a catch all type error message?

I tried Vmware 4.xx and simulator 1.07 and 1.08  and 2.0 without success. I will later try vmware 3.15 and simulator  2.0 to see what happens.