Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
misterza
Posts: 19
Registered: ‎06-28-2010
My Device: n/a
My Carrier: n/a

ASP.net GridView buttons not working

Hi all,

 

I have an ASP.NET web application which is accessed through a widget. I can't get any command buttons such as "Select" to work. The events do not fire, but they work fine when I view the site in my desktop browser.

 

Is the GridView supported on blackberrys?

Please use plain text.
Contributor
misterza
Posts: 19
Registered: ‎06-28-2010
My Device: n/a
My Carrier: n/a

Re: ASP.net GridView buttons not working

Some more info: I'm targetting .NET 3.5

 

When I debug I get the error "__doPostBack is not defined"

 

I have followed the instructions at "How To - Configure .NET 2.0 for BlackBerry Browser support" but it still dosn't work.

 

Can anybody help?

Please use plain text.
Contributor
misterza
Posts: 19
Registered: ‎06-28-2010
My Device: n/a
My Carrier: n/a

Re: ASP.net GridView buttons not working

I solved the problem by creating an App_Browsers folder in my solution, and then copied the BlackBerry.browser file from .NET 4.0

 

The file is below

 

<browsers>
    <!-- BlackBerry9000/4.6.0.266 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/120 -->
    <browser id="BlackBerry" parentID="Default">
        <identification>
            <userAgent match="BlackBerry(?'deviceName'\w+)/(?'version'(?'major'\d+)(\.(?'minor'\d+)?)\w*)" />
        </identification>

        <capabilities>
            <capability name="layoutEngine"                    value="BlackBerry" />
            <capability name="browser"                         value="BlackBerry" />
            <capability name="majorversion"                    value="${major}" />
            <capability name="minorversion"                    value="${minor}" />
            <capability name="type"                            value="BlackBerry${major}" />
            <capability name="mobileDeviceModel"               value="${deviceName}" />
            <capability name="isMobileDevice"                  value="true" />
            <capability name="version"                         value="${version}" />
            <capability name="ecmascriptversion"               value="3.0" />
            <capability name="javascript"                      value="true" />
            <capability name="javascriptversion"               value="1.3" />
            <capability name="w3cdomversion"                   value="1.0" />
            <capability name="supportsAccesskeyAttribute"      value="true" />
            <capability name="tagwriter"                       value="System.Web.UI.HtmlTextWriter" />
            <capability name="cookies"                         value="true" />
            <capability name="frames"                          value="true" />
            <capability name="javaapplets"                     value="true" />
            <capability name="supportsCallback"                value="true" />
            <capability name="supportsDivNoWrap"               value="false" />
            <capability name="supportsFileUpload"              value="true" />
            <capability name="supportsMultilineTextBoxDisplay" value="true" />
            <capability name="supportsXmlHttp"                 value="true" />
            <capability name="tables"                          value="true" />
            <capability name="canInitiateVoiceCall"            value="true" />
        </capabilities>
    </browser>
</browsers>

Please use plain text.
New Member
micktxh
Posts: 1
Registered: ‎10-24-2011
My Device: Storm 2 9530
My Carrier: -

Re: ASP.net GridView buttons not working

Hi, I need my gridview to be able to work with blackberry as well, but when i tried out ur post, i was returned with the following error:

 

Parser Error Message: parsing "BlackBerry(?'deviceName'\w+)/(?'version'(?'?major'\d+)(\.(?'minor'\d+)?)\w*)" - Invalid group name: Group names must begin with a word character.

would you have any idea what i may have done wrong ?

Please use plain text.