Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
Posts: 12
Registered: ‎12-18-2012
My Device: Developer
My Carrier: O2

App doesn't display properly.

I have written a webworks app, and it displays fine in the Blackberry web browser, but not when actually loaded as an app.
Thank You for any help.
Developer
Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: App doesn't display properly.

What works in the browser may not be the same for webworks compiled app (thinking thats obvious from your post).  What I mean is: a web page / app does not have the config / manifest that an webworks app has and needs.  While you can take a web / html5 app and convert it into a webworks app, it won't work straight away with the adjustments.

 

Are you able to supply code for this app?

If it helped you, click like. Smiley Happy
Contributor
Posts: 12
Registered: ‎12-18-2012
My Device: Developer
My Carrier: O2

Re: App doesn't display properly.

Ok, I think that I now understand this a bit better. This is a link to the code: wootton-house.com/app/latin/index.html

My problem is that although I know about the compiling and everything, I don't know how to find out what is going wrong.

Highlighted
Developer
Posts: 136
Registered: ‎02-01-2009
My Device: Not Specified

Re: App doesn't display properly.

I havent seen your page, but can you check you 'meta' tag, specially the initial-scale value and other defaults.

You can find an easy sample to copy paste from the bbUI wiki
Contributor
Posts: 12
Registered: ‎12-18-2012
My Device: Developer
My Carrier: O2

Re: App doesn't display properly.

Ok, I think that I will have a look at that. Might the problem be that I defined sizes in the CSS with percentages?