Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
mannymisc
Posts: 9
Registered: ‎11-16-2011
My Device: 9300
My Carrier: NA

App not working on phones with BES

Hello,

 

We have our app released on appworld.  It is a web works app. The app authenticates to a server via https. Our app works fine on all BB phones except those that have Blackberry Enterprise Servers. Users who connect through BES cannot get the app to authenticate their details. Any suggestions?

 

 

Please use plain text.
Administrator
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: App not working on phones with BES

Are all of your uses on the same BES?  If so, there may be an IT policy in place where the admin has locked down this type of control for 3rd party apps.  

 

Can you authenticate your SSL site using the browser application?  If not, I'd suggest looking into your certificate as I suspect there is something invalid with it.

 

 

Finally, did you know you can define a prioritized order of network transports that your app will use to connect:

https://bdsc.webapps.blackberry.com/html5/documentation/ww_developing/id_element_834682_11.html

 

If you sort this list such that BES is below BIS, it may resolve the issue for some users.

 

 

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Please use plain text.