Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
Posts: 23
Registered: ‎08-29-2012
My Device: Dev Alpha
Accepted Solution

App won't start on dev alpha anymore

Downloaded the new bb10 webworks sdk 10.0.2.9, was previously using 10.0.1.17.

 

When app start, it will stay in the grey screen that says blackberry, then dies with "Application did not open a window within the allotted time and has been slayed."  App runs fine on Ripple and if packaged with 10.0.1.17.

 

checked the bar files and found the new package missing jnext.so and pps.so.  If I manually put in those two files and modified the manifest, then it'll run.  What have I done?  Am I missing something in the new sdk?

 

Wilson

 

 

New Developer
Posts: 23
Registered: ‎08-29-2012
My Device: Dev Alpha

Re: App won't start on dev alpha anymore

placing pps.so from 10.0.1.17 in <SDK>/Framework/dependencies/jnext solves the problem for now. However, the dialog that shows my ip and port for web inspector is sooooo HUGE that it takes up my whole screen. Everything else works fine.
BlackBerry Development Advisor
Posts: 624
Registered: ‎10-01-2009
My Device: Z10

Re: App won't start on dev alpha anymore

Are you packaging it in Ripple too?

 

If so, in your output directory, there should be a sub-directory called Device.  Go in there, and that is the .bar file you'll want to load on to your dev alpha.  This is a bug in ripple right now, where it loads the simulator .bar file instead of the device .bar file.

 

That should clear up any issues.

Chad Tetreault | App Development Consultant | BlackBerry Developer Relations | developer.blackberry.com | @chadtatro
BlackBerry Development Advisor
Posts: 37
Registered: ‎01-08-2010
My Device: Various

Re: App won't start on dev alpha anymore

The new version of Ripple released yesterday should resolve the deployment issue, so please make sure you update that and try again.

 

The pps.so and jnext.so files are no longer required in the .bar. If included, WebWorks will use the .bar version instead of the version in the runtime. You've likely converted a simulator version of your app to a device version of your app by including the proper binaries.

 

If you get the latest version of Ripple and everything works fine could you please let me know? If there are any major issues with the latest release we can patch if necessary.

New Developer
Posts: 23
Registered: ‎08-29-2012
My Device: Dev Alpha

Re: App won't start on dev alpha anymore

I used command line to do everything. Ripple never worked for me in terms of deployment, not sure if it's because I'm on linux.
New Developer
Posts: 23
Registered: ‎08-29-2012
My Device: Dev Alpha

Re: App won't start on dev alpha anymore

Let me update to dev alpha 10.0.9 and report back. I'm currently on 10.0.6.

BlackBerry Development Advisor
Posts: 37
Registered: ‎01-08-2010
My Device: Various

Re: App won't start on dev alpha anymore

That explains it. There is no chance that it will work other than on the latest release of the OS.

BlackBerry Development Advisor
Posts: 115
Registered: ‎06-06-2011
My Device: 9800

Re: App won't start on dev alpha anymore

You don't need jnext and pps.so in the bar anymore

 

They are on the 10.0.09 device image. webworks loads it from device. Putting it in the bar will mess with everything with the latest SDK, bad idea

@nukulb
New Developer
Posts: 23
Registered: ‎08-29-2012
My Device: Dev Alpha

Re: App won't start on dev alpha anymore

That was easy. Thanks.