Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
francalero
Posts: 3
Registered: ‎05-27-2013
My Device: BlackBerry PlayBook 16GB - WiFi
My Carrier: N/a

Audio Streaming Problemas

[ Edited ]

Hi everyone!

 

i am new here, i just start to develop m firs web app for my PlayBook.

 

I am triying to build a Radio Stream from my favourite Radio Stations in my country (Honduras).

 

i am implementing JPlayer (customized by myself), it work work fine in Chrome browser, Firefox,  IE, and of course in the PlayBook Browser too, but i am having problems for the streaming in my Playbook cannot start or maybe cannot connect to the server.

 

<script type="text/javascript">
//<![CDATA[
$(document).ready(function(){

	new jPlayerPlaylist({
		jPlayer: "#jquery_jplayer_2",
		cssSelectorAncestor: "#jp_container_2"
	}, [
		{
			title:"Radio W105 - La Radio del Flow",
			mp3:"http://69.175.122.202:8203/;stream.mp3",
			//oga:"http://69.175.122.202:8203/;stream.ogg",
			//wav:"http://69.175.122.202:8203/;stream.wav",
			//ogg:"http://69.175.122.202:8203/;stream.ogg"
		},
		{
			title:"Radio W107 - Aqui Todo Comenzo",
			mp3:"http://64.150.176.192:8311/;stream.mp3",
			//oga:"http://64.150.176.192:8311/;stream.ogg",
			//wav:"http://64.150.176.192:8311/;stream.wav"
			},
		{
			title:"Stereo Palmeras",
			mp3:"http://stereopalmeras.com:8000/sp.mp3",
		},
		{
			title:"XY 107.5",
			mp3:"http://luxweradio2.luxwer.net:8221/;stream.mp3",
			
		},
				
		{
			title:"Hidden",
			mp3:"http://www.jplayer.org/audio/mp3/Miaow-02-Hidden.mp3",
			oga:"http://www.jplayer.org/audio/ogg/Miaow-02-Hidden.ogg"
		},
		{
			title:"Lentement",
			free:true,
			mp3:"http://www.jplayer.org/audio/mp3/Miaow-03-Lentement.mp3",
			oga:"http://www.jplayer.org/audio/ogg/Miaow-03-Lentement.ogg"
		},
		{
			title:"Lismore",
			mp3:"http://www.jplayer.org/audio/mp3/Miaow-04-Lismore.mp3",
			oga:"http://www.jplayer.org/audio/ogg/Miaow-04-Lismore.ogg"
		},
		{
			title:"The Separation",
			mp3:"http://www.jplayer.org/audio/mp3/Miaow-05-The-separation.mp3",
			oga:"http://www.jplayer.org/audio/ogg/Miaow-05-The-separation.ogg"
		},
		
	],
	{
		swfPath: "js",
		//solution: "html",
		supplied: "oga, mp3, wav",
		wmode: "window",
		smoothPlayBar: true,
		keyEnabled: true
		//errorAlerts: true,
	});
});
//]]>
</script>

  

 

Also i deffine the  access in the config.xml 

 

<?xml version="1.0" encoding="UTF-8"?>
<widget xmlns="http://www.w3.org/ns/widgets"
xmlns:rim="http://www.blackberry.com/ns/widgets"
version="1.0.0.0" id="HelloWorldApp">

<access uri="http://69.175.122.202" subdomains="true"/> 
<access uri="http://www.radiow105.com" subdomains="true"/>

</widget>

 

 

My webapp works fine (streaming) in Chrome and IE 10, but for some reason cannot play in My PlayBook and Firefox.

tried packing the app and in the browser, but i still not working.

 

i hope can give me a hand with it, i want send it to the BB World for free, is just a hobbie for me.

 

thank you

 

update 1:

after thinking is i have some problems about proxy i tried this even if i can stream with chrome and IE i decide try something.

1-  install a software to change my proxy (i live in china, many restrictions).

  1.1 - this for itself didnt work.

2-  i set my link to reproduce only in mp3.

 

results: change the proxy and set the link to reproduce mp3 make my code work perfect in my computer but int the playbook is not working (i cannot change my proxy in the playbook).

Please use plain text.
Administrator
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Audio Streaming Problemas

It sounds like it is still an access whitelisting issue.  Suggest try adding the following and testing again:

 

<access uri="*" subdomains="true"/> 

 

I suspect the domain / IP of the remote stream may be different than expected.

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Please use plain text.
New Contributor
francalero
Posts: 3
Registered: ‎05-27-2013
My Device: BlackBerry PlayBook 16GB - WiFi
My Carrier: N/a

Re: Audio Streaming Problemas

I had try it, but not work for me.

it is showing the loading bar, but not playing the audio.
Yeserda i got the message "Multimedia Error" i think is something with the format.
After that i try to the original audio sample from JPlayer and it work perfect

JPlayer original Sample code:
{
title:"Lentement",
free:true,
mp3:"http://www.jplayer.org/audio/mp3/Miaow-03-Lentement.mp3",
oga:"http://www.jplayer.org/audio/ogg/Miaow-03-Lentement.ogg"
},
Please use plain text.
New Contributor
francalero
Posts: 3
Registered: ‎05-27-2013
My Device: BlackBerry PlayBook 16GB - WiFi
My Carrier: N/a

Re: Audio Streaming Problemas

[ Edited ]

i keep trying to fix it, i found in the forums this

http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/help-Playing-an-audio-file-using...

and i make it work (in Google Chrome) playbook just say the multimedia content is loading to slow i wait but never load.

 

are 2 different radio stations

1 button for each radio.

<!DOCTYPE html>
<html>

<head>
<script type="text/javascript" src="sound.js"></script>

<script id="main" type="text/javascript">
function init() {
    // Setup our background music
    playSound("http://64.150.176.192:8311/;stream.mp3", 9999, 0.2, 0);
	}
</script>
	
</head>
<body>

<audio preload="auto" autobuffer id="audio">
  <source src="http://69.175.122.202:8203/;stream.wav">
</audio> 

	<p>
		<H1>Radio W105 La Radio Del Flow onclick="document.getElementById('audio').play()"</h1>
		<div>
		<button type="button" onclick="document.getElementById('audio').play()">Click Me!  </button>
		  
		</div>
		<!--<audio controls="controls" autoplay="autoplay">
			<source
				src="http://69.175.122.202:8203/;stream.mp3" type="audio/mpeg" />
		</audio>-->
	</p>
	
	<button type="button" onclick="init()">Click Me again!  </button>
</body>
</html>

 



i am thinking my issue is related with the way i declare the server address.

Some idea?

Please use plain text.
BlackBerry Development Advisor
anzor_b
Posts: 164
Registered: ‎09-24-2012
My Device: White BlackBerry 10
My Carrier: Bell

Re: Audio Streaming Problemas

Hi francalero,

 

RFC3986 describes the semi-colon (:smileywink: as a delimiter character, which is reserved for special use when passed as URL. From your description it sounds like URLs without this character work. Maybe other browsers are more lenient, but have you tried other URLs without a semi-colon?

Please use plain text.