If you are using Internet Explorer, please remove blackberry.com from your compatibility view settings.

Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Trusted Contributor
usr501
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900
My Carrier: rogers
Accepted Solution

BB10 Signing issue command line says:

command line says:

Error: Code signing request failed because this version of the application or package has been previously signed. Please increment the version(s) and try signing again.


manifest says:

Archive-Manifest-Version: 1.5

Archive-Created-By: BlackBerry Elf BAR Packager 1.7

Package-Type: application

Package-Author: The Blue Gystrophacy

Package-Author-Id: testVGhlIEJsdWUgR3lzdHJvcGg

Package-Name: ras

Package-Id: testRel_ras________1b824___

Package-Version: 1.0.2.1

Package-Version-Id: testMS4wLjIuMSAgICAgICAgICA

Package-Architecture: armle-v7

Application-Name: SiteManager

Application-Id: testRel_ras________1b824___

Application-Description: Toolkit for Constructors

Application-Version: 1.0.2.1

Application-Version-Id: testMS4wLjIuMSAgICAgICAgICA

Application-Requires-System: Tablet OS/10.0.4.0

Application-Development-Mode: false

Entry-Point-Name: SiteManager

Entry-Point-Key: e1

Entry-Point: WEBKIT_NUMBER_OF_BACKINGSTORE_TILES=12 app/native/wwe

Entry-Point-Type: Qnx/Elf

Entry-Point-Icon: {86x86}native/resources/icon-86.png:{150x150}native/resources/icon-150.png

Entry-Point-Splash-Screen: {1280x768}native/resources/splash-1280x768.png:{768x1280}native/resources/splash-768x1280.png

Entry-Point-Orientation: auto

Entry-Point-User-Actions: access_internet

Entry-Point-System-Actions: run_native

 

I changed the version number twice now and still am getting this. any ideas?

Please use plain text.
BlackBerry Development Advisor (Retired)
rtse
Posts: 5
Registered: ‎07-26-2011
My Device: 9800
My Carrier: Rogers

Re: BB10 Signing issue command line says:

How did you specify the build id? Can you paste the exact command?
Please use plain text.
Trusted Contributor
usr501
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900
My Carrier: rogers

Re: BB10 Signing issue command line says:

built using the 'package' option in Ripple

Please use plain text.
Developer
The_Anomaly
Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: BB10 Signing issue command line says:

In the sample you provided your package version is:

Package-Version: 1.0.2.1

 

Do you increment this?  Maybe to:

Package-Version: 1.0.2.2

 

That error happens to me when I forget what version I last compiled an app on, while compiling an app on another machine.  So on machine A my last compile was 1.0.2.1 and on machine B I go and compile 1.0.2.0 or something less.  You need to increment each time going up.

 

Is that what you did?

If it helped you, click like. :smileyhappy:
Please use plain text.
Trusted Contributor
usr501
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900
My Carrier: rogers

Re: BB10 Signing issue command line says:

yes, I have the xml file open along with the about html file open when building and increment the builds in two places before proceeding with build.

 

Please use plain text.
Trusted Contributor
usr501
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900
My Carrier: rogers

Re: BB10 Signing issue command line says:

User Error:

in ripple settings archive name  I had capitalized the s in sitemanager :smileyvery-happy:

Please use plain text.