Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Trusted Contributor
usr501
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900
Accepted Solution

BB10 external links not working

here's the script:

<script type="text/javascript">

 

function onInvokeSuccess() {
    alert("Invocation successful!");
}

function onInvokeError(error) {
    alert("Invocation failed, error: " + error);

function openWebLinkInBrowser() {
    // open web link in browser
    blackberry.invoke.invoke({
        target: "sys.browser",
        uri: "http://brooklynn.ky/sitemanager/"
    }, onInvokeSuccess, onInvokeError);
}</script>

 

here's the xml:

 <content src="index.html" rim:allowInvokeParams="true"/>
    <!-- Expose access to all URIs, http protocols -->
     <access uri="http://brooklynn.ky/sitemanager/" subdomains="true">
  <feature id="blackberry.ui.dialog" required="true" version="1.0.0.0"/>
  <feature id="blackberry.app" required="true" version="1.0.0"/>
  <feature id="blackberry.invoke" required="true" version="1.0.0"/>
  </access>

Please use plain text.
BlackBerry Development Advisor
Nukul
Posts: 115
Registered: ‎06-06-2011
My Device: 9800

Re: BB10 external links not working

What device build are you using?
@nukulb
Please use plain text.
Trusted Contributor
usr501
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900

Re: BB10 external links not working

webworks SDK 1.0.2.9
Please use plain text.
BlackBerry Development Advisor
Nukul
Posts: 115
Registered: ‎06-06-2011
My Device: 9800

Re: BB10 external links not working

Sorry I think you mis-understood I said device build.

What device or simulator are you deploying to?

 

You can go to settings-> About --> OS --> Os Version

@nukulb
Please use plain text.
Trusted Contributor
usr501
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900

Re: BB10 external links not working

Dev Alpha 10.0.9.388
Please use plain text.
Retired
erikjohnzon
Posts: 245
Registered: ‎09-21-2012
My Device: Q10

Re: BB10 external links not working

I tested it on 10.0.9.497 and it works as desired. I did have to add a bracket since your on error function does not have a closing brace, but that might have just been an entry error in your post. Can you confirm that you are getting to the error callback? Or what behaviour you mean by "not working"?

@erikjohnzon
erjohnson@blackberry.com
Please use plain text.
BlackBerry Development Advisor
Nukul
Posts: 115
Registered: ‎06-06-2011
My Device: 9800

Re: BB10 external links not working

That is probably the problem , the ending brace
@nukulb
Please use plain text.
Trusted Contributor
usr501
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900

Re: BB10 external links not working

erikjohnzon,

the links work in ripple but not on BB10 dev alpha device.

the brace is there. will confirm error callback.

 

how does one get an update to 10.0.9.497?

Please use plain text.
New Contributor
erikjonzon
Posts: 2
Registered: ‎09-21-2012
My Device: Bold 9900

Re: BB10 external links not working

If you can confirm the error callback it should tell you something ie: INVOKE_NO_TARGETS, INVOKE_QUERY_ERROR etc, then we can go from there.

 

It's an internal build, so you probably won't see it for a bit. It was just the closest OS I had loaded to yours. I'll load your version up if we can't get anywhere with the error callback.

@erikjohnzon
erjohnson@rim.com
Please use plain text.
Trusted Contributor
usr501
Posts: 222
Registered: ‎03-03-2012
My Device: Ripple, LE Z10, Dev Alpha _C, Playbook, Bold 9900

Re: BB10 external links not working

erikjohnzon,

can I send you the file?

 

Please use plain text.