Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
Developer
LBP
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none
Accepted Solution

BB10 - graphic issues running more than one app

Hi there,

 

I saw this in the past on older builds and even with the latest OS build 10.0.9.2320 I got graphic issue running more than one app at same time. Is this a general bug in the OS graphic driver or something like this, or an issue in the Framework? Here is a picture of how it looks like in a testing app:

 

IMG_00000098.jpg


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Please use plain text.
Developer
willyyr
Posts: 229
Registered: ‎08-14-2009
My Device: Bold 9900, DevAlpha A
My Carrier: Vodafone DE

Re: BB10 - graphic issues running more than one app

Hey LBP, 

i'm having the same issue running a devalpha A on latest fw with my webworks/bbui app. Could anyone look into this, i think my app got rejected for BFB because of this. It happens mostly when i invoke the browser from within my app (the browser gets completly messed up and is not usable) or if the browser is open and i start my app. Also running multiple webworks apps seem to cause those issues as well. 

Willy R.
-
If my post solved your problem, make it easier for others to find by Accepting it as a solution or provide a Kudo if it was helpful for you. Thanks.
Please use plain text.
Developer
Developer
LBP
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: BB10 - graphic issues running more than one app

Dear willyyr,

 

another issue we are we have noticed using more than 3 apps. Most times you are opening the 4th app another app will be closed and sometimes it seem to be impossible to open a 4th app. We could find out why that didn't happen so far using a previous version of the OS/SDK.

 

Regards.


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Please use plain text.
Trusted Contributor
neilwick
Posts: 176
Registered: ‎01-20-2013
My Device: Bold 9790
My Carrier: Telus

Re: BB10 - graphic issues running more than one app

[ Edited ]

This situation is really annoying. I haven't found any way around it. It seems to happen every time I have a Webworks app running at the same time as the browser or even sometimes when I have two Webworks programs running along with BlackBerry World, for example.

 

This is my app:

IMG_00000068.png

 

This is the browser trying to display a Wikipedia page (the "W" is the test link in my app):

IMG_00000070.png

 

This is a Dev Alpha A running 10.9.9.339

 

Please use plain text.
Developer
biggerCC
Posts: 270
Registered: ‎12-13-2010
My Device: PlayBook 16GB, BB10 Dev Alpha
My Carrier: o2 (de)

Re: BB10 - graphic issues running more than one app

I have the same problems on my Dev Alpha A (most current software). They occur as soon as more than one WebView is opened. The first/second app can also be the browser.

 

Looks like some GPU / driver bug in the A-series...

- - -
My approved apps @ App World
Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: BB10 - graphic issues running more than one app

We have a twitter thread on this as well.  The Dev Alpha Devices have memory limitations compared to the gold OS running on production BB10 devices.

 

This is a current known limitation of the DevAlpha devices and I can assure you it doesn't happen on the production hardware.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
Developer
biggerCC
Posts: 270
Registered: ‎12-13-2010
My Device: PlayBook 16GB, BB10 Dev Alpha
My Carrier: o2 (de)

Re: BB10 - graphic issues running more than one app

Thanks for clarification, Tim.

First came my response on this thread, then your update on Twitter. :smileywink:

 

I hope you'll bring a batch of Z10s to Amsterdam for devs to play with. I can't wait to optimize my projects in terms of performance and can't wait for my limited edition device...

- - -
My approved apps @ App World
Please use plain text.
Developer
willyyr
Posts: 229
Registered: ‎08-14-2009
My Device: Bold 9900, DevAlpha A
My Carrier: Vodafone DE

Re: BB10 - graphic issues running more than one app

Thanks Tim, i was just about to post our twitter thread as well. Glad to hear it's all solved on Gold HW+OS. 

Willy R.
-
If my post solved your problem, make it easier for others to find by Accepting it as a solution or provide a Kudo if it was helpful for you. Thanks.
Please use plain text.
Developer
Developer
LBP
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: BB10 - graphic issues running more than one app

Hi Tim,

 

thanks for your information on this. Seems we all need an updated device :Yes:. You mentioned the memory limitations, is there a higher amount of memory in the production BB10 devices?

 

Regards

LBP


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: BB10 - graphic issues running more than one app

Unfortunately, I can't really comment on production hardware specifications. All will be reveled on the 30th
Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.