Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
spikegotti
Posts: 45
Registered: ‎05-01-2013
My Device: Z10
My Carrier: LIME
Accepted Solution

Black Screen display after splash screen in BB10 HTML5 app

Hi , Im having a 3 second black screen after the splash screen, is there anyway to fix this?

Please use plain text.
Developer
wantoun
Posts: 165
Registered: ‎10-04-2010
My Device: P'9982 & Z10
My Carrier: alfa Lebanon

Re: Black Screen display after splash screen in BB10 HTML5 app

I'm having the same problem with my WebWorks apps sometimes.

I'm still unable to trace it and see its cause but I get a white screen for 5-6 seconds before my app shows.

 

I'm not sure if this has to do with the App itself or the OS, because I notice the same thing happens with the Settings App in the OS sometimes!

Wadi
Please use plain text.
Developer
spikegotti
Posts: 45
Registered: ‎05-01-2013
My Device: Z10
My Carrier: LIME

Re: Black Screen display after splash screen in BB10 HTML5 app

[ Edited ]

Yes I have noticed this too with the settings app. What bugs me is that my game was denied for the 3 second delay.

Every single day my game is denied for some reason that I can prove as false, because I do not test on the simulator, I always test on 3 Z10 devices to ensure device functionality. Im really worried about my code since its easy to extract the contents from a .Bar file.

Please use plain text.
BlackBerry Development Advisor (Retired)
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Black Screen display after splash screen in BB10 HTML5 app

Can you describe what your application does during startup?

 

Have you connected it to remote web inspector and tried profiling performance (using the Network panel)?  Curious if its trying to download a lot of remote resources during startup which is blocking the UI.

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Please use plain text.
Developer
spikegotti
Posts: 45
Registered: ‎05-01-2013
My Device: Z10
My Carrier: LIME

Re: Black Screen display after splash screen in BB10 HTML5 app

Thanks astanley, I managed to work around it by allowing the second splash screen to show whilst the first layout loads :smileyhappy:
Please use plain text.
BlackBerry Development Advisor
chadtatro
Posts: 619
Registered: ‎10-01-2009
My Device: Z10
My Carrier: Bell

Re: Black Screen display after splash screen in BB10 HTML5 app

I agree with Adam :smileyhappy:

 

The only time I've come across this type of thing is when the application is "waiting" for something to happen before displaying the screen, or pushing a new view (if you happen to be using something like bbUI).

 

I'd really recommend that if you are downloading anything resources (libraries, images, etc) when the app loads, to not do that, and instead package them locally.

 

If you really must include any libraries/sources that are hosted remotely, I would put the script include at the bottom of your index.html before the closing </body> tag rather than at the top of the index file.

Chad Tetreault | App Development Consultant | BlackBerry Developer Relations | developer.blackberry.com | @chadtatro
Please use plain text.
Developer
spikegotti
Posts: 45
Registered: ‎05-01-2013
My Device: Z10
My Carrier: LIME

Re: Black Screen display after splash screen in BB10 HTML5 app

Thanks for the tip and help :smileyhappy:... i just reloaded the OS on my Z10 and restored my backup, now Im seeing hundreds of the same email and its frustrating having to select one by one. Is it possible that we can have the Select All feature on BB10? Its really time consuming that way.
Please use plain text.
Trusted Contributor
lathajagan
Posts: 118
Registered: ‎03-06-2013
My Device: Blackberry Z10
My Carrier: Airtel

Re: Black Screen display after splash screen in BB10 HTML5 app

@spikegotti , the problem of the issue u have posted, is because the html page you are loading might be taking too long to load, and also you might be switching between 2 html pages, which shows this kind of black screen before the original screen is shown and after splash screen, to solve the problem try to load only one html with all the content , and before loading your html, try using rim:splash element inn BB10 webworks to avoid black screen shown.
--------
- If a post contains the solution to the problem, please click "Accept as Solution"
- If a post contains helpful content, please give it a "Thumbs Up"

developer.blackberry.com
@BlackBerryDev
Please use plain text.
Developer
spikegotti
Posts: 45
Registered: ‎05-01-2013
My Device: Z10
My Carrier: LIME

Re: Black Screen display after splash screen in BB10 HTML5 app

Problem solved, but actually, I only use one html file and thats the index.
Please use plain text.