Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
langsky
Posts: 25
Registered: ‎12-21-2009
My Device: BlackBerry Z10

BlackBerry 10 Webworks app not working on Verizon Z10

I received my new BlackBerry Z10 from Verizon yesterday and loaded up my Webworks app.  I was shocked when it did not function properly on the Verizon Z10 and kept locking up.  It worked great on my Dev Alpha.  Any ideas?  Is there something different with the Verizon Z10?  I removed my app from sale as I do not want people with a Verizon Z10 to download this app currently.

Developer
langsky
Posts: 25
Registered: ‎12-21-2009
My Device: BlackBerry Z10

Re: BlackBerry 10 Webworks app not working on Verizon Z10

I do not know what else to do.  I have compiled this with the latest Webworks SDK and it continues to freeze up on the Verizon Z10.  I have not been able to test it on the AT&T Z10, but it did run smooth as silk on the Dev Alpha.

 

Is no one else experiencing this?  I am finding a number of apps that are not available for the Verizon Z10.  This is very frustrating and it needs to be fixed ASAP or people are going to blame this on BlackBerry and return their Z10's to Verizon and switch to a different platform.

Retired
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: BlackBerry 10 Webworks app not working on Verizon Z10

In the App World vendor portal, you don't have to remove your app from all users.  You can select only those carriers you want.  So if you'd like to make it availalbe to all other US carriers except Verizon, that is within your control.

 

Verizon has their own variant of the Z10 device hardware.  I suspect there might be something incompatible, but can't say for sure.

 

What does your application do?  Lots of intense graphics, multimedia, platform integration, etc?

 

Does it freeze on startup, or after a period of use (if so recommend using remote web inspector to debug)?

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Developer
langsky
Posts: 25
Registered: ‎12-21-2009
My Device: BlackBerry Z10

Re: BlackBerry 10 Webworks app not working on Verizon Z10

Thanks Adam. I am going to use web inspector to see what I can find out. Now I wonder if it works ok on the AT&T/T-Mobile variants. The app is Color WhatsIt. Although it is currently not for sale as I stated earlier. Once I verify this works on other carriers for sure I will put it back up for sale.
Developer
langsky
Posts: 25
Registered: ‎12-21-2009
My Device: BlackBerry Z10

Re: BlackBerry 10 Webworks app not working on Verizon Z10

OK, I have been doing some testing and I can not for the life of me figure out what is going on.  The app ran great on the Dev Alpha and it runs great in Ripple, but it freezes on both the Verizon Z10 and the LE with the latest OS on it.  I could not determine why from web inspector.  It is just weird that it runs great in ripple, but not on device.

Developer
langsky
Posts: 25
Registered: ‎12-21-2009
My Device: BlackBerry Z10

Re: BlackBerry 10 Webworks app not working on Verizon Z10

This app has a lot of CSS animations and it does not freeze on startup, rather it seems to freeze after a few animations have been performed.

BlackBerry Development Advisor
anzor_b
Posts: 165
Registered: ‎09-24-2012
My Device: Passport

Re: BlackBerry 10 Webworks app not working on Verizon Z10

Hi langsky,

 

The dev alpha and Z10 have different chipsets, but this should only affect select WebGL functionality. I use CSS3 animations heavily and I have no issues on either.

 

Can you define freezing? Do you see this while scrolling? Maybe take a video and post a link here? Are you using some kind of framework? 

Developer
langsky
Posts: 25
Registered: ‎12-21-2009
My Device: BlackBerry Z10

Re: BlackBerry 10 Webworks app not working on Verizon Z10

I think it might be a cache issue. After a couple button clicks, it appears to freeze, but if I wait longer it eventually finishes the action. I am using Zepto. I will try to post some video.