Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
ttrumm
Posts: 3
Registered: ‎02-23-2009
My Device: Not Specified

BlackBerry 9000: broken image on 304 not modified

Hi.


There seems to be an issue with the browser cache of the BlackBerry 9000.
Some images get broken if the server sends a "304 not modified" response.

Steps to reproduce the problem:

Create an XHTML page with an image on it which has an expiration time of 60 seconds (for example with apache mod_expires)
On the page place a link to itself.
Open the browser, clear the cache and history
Open the page via the "Go To..." menu entry
Page and image is displayed properly
Wait >1 minute, click the self link
The browser sends a request and adds an "If-Modified-Since" header
The server answers with "304 Not Modified"
The image is broken now

Tested devices:
T-Mobile, Web&Walk Browser, BlackBerry 9000,, v4.6.0.92 (Platform 4.0.0.117)
Vodafone, Internet-Browser, BlackBerry 9000, v4.6.0.125 (Platform 4.0.0.134)

This cannot be reproduced using the simulator.

Any idea?

Thanks.

BlackBerry Development Advisor
MSohm
Posts: 14,757
Registered: ‎07-09-2008
My Device: BlackBerry Passport

Re: BlackBerry 9000: broken image on 304 not modified

What browser are you testing with, the BlackBerry Browser (BlackBerry Enterprise Server), Internet Browser (BlackBerry Internet Service) or WAP Browser (carrier's WAP Gateway)?  You can check your default browser setting by going to Options, Advanced Options, Browser.
Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
New Developer
ttrumm
Posts: 3
Registered: ‎02-23-2009
My Device: Not Specified

Re: BlackBerry 9000: broken image on 304 not modified

[ Edited ]

Hi,

 

On the first device the browser is called "web'n'walk" which I think is an alias for the Internet Browser
The browser of the second device is called "vodafone live".
 
Thanks

 

 

Message Edited by ttrumm on 02-26-2009 07:27 AM
Guru I
Xandrex
Posts: 18,406
Registered: ‎07-29-2008
My Device: Z30, Playbook, 9320BES
My Carrier: B&You _ SFR

Re: BlackBerry 9000: broken image on 304 not modified


ttrumm wrote:

Hi,

 

On the first device the browser is called "web'n'walk" which I think is an alias for the Internet Browser
The browser of the second device is called "vodafone live".

the Web'n'Walk is the browser that uses the T-Mobile proxy. http://www.webnwalk.co.uk/
the "Vodafone Live" is the browser that uses the Vodafone UK proxy.



The search box on top-right of this page is your true friend, and the public Knowledge Base too:
New Developer
ttrumm
Posts: 3
Registered: ‎02-23-2009
My Device: Not Specified

Re: BlackBerry 9000: broken image on 304 not modified

Hi,

I also verified this problem with an Orange UK device v4.6.0.125 (Platform 4.0.0.134)
Browser Configuration: "Internet Browser"

 

best regards

Retired
saziz
Posts: 76
Registered: ‎07-11-2008
My Device: Z10

Re: BlackBerry 9000: broken image on 304 not modified

Do you happen to have a publicly facing test URL that demonstrates the issue?
Sarim
BlackBerry Development Advisor
www.BlackBerryDeveloper.com