Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Regular Contributor
Posts: 83
Registered: ‎04-29-2011
My Device: 9300 Curve
Accepted Solution

BlackBerry WebWorks - Eclipse

Hello there,

 

I get a little confused here.

 

Here's my problem:

 

I have a BlackBerry WebWorks working on Eclipse environment (BlackBerry WebWorks Plug-In 2.5.1.*) and BlackBerry WebWorks SDK Plug-in (2.0.0.*), OK?

 

So, the thing is: I'm getting an error "ClassNotFoundException" in my application. I have two .jar in the "ext" directory. One is my custom packet called Database.jar (where i make the db access with sqlite and so on (this is a phonegap plugin)) and the phonegap.0.9.4.jar that's the framework.

 

That's fine. Everything works fine like a charm when i compile using bbwp.exe version 1.5. But, when i compile with the SDK 2.0, i get ClassNotFoundException. I'm looking for the class that's not finding. That's fine too.

 

I would like to know one thing: How is possible to debug java code in this environment?!?!?!? I have no IDEA how to doit! I'm doing the java code by my mind!!! It's crazy!!

Márcio Saeger - Software Engineer, Softwell Solutions
Regular Contributor
Posts: 83
Registered: ‎04-29-2011
My Device: 9300 Curve

Re: BlackBerry WebWorks - Eclipse

Hello again everybody (who read this thread).

The thing is: I already knew the answers.. but that error was making me crazy.
The problem of the "ClassNotFoundException" was: I extracted my Database.jar.
Just that! Since SDK 1.5, it was inside the jar and now i extracted the jar into the "ext" folder and everything works like a charm...
Strange.

That's it. This is the answer for my thread. Thanks again.

PS: The question about "how to debug java code into WebWorks Eclipse still...". If anyone can answer to me...
Márcio Saeger - Software Engineer, Softwell Solutions