Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
companya
Posts: 10
Registered: ‎01-06-2012
My Device: 9900
My Carrier: rogers

Blackberry 5.0 email can't get images

I can't "Get images" when in HTML email on 9700 OS 5.0. All appropriate settings in email account are on. I have tried sending from multiple different emails and designs with images, none appear?

 

Receive html email > click on Get images > nothing

Please use plain text.
BlackBerry Development Advisor (Retired)
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Blackberry 5.0 email can't get images

What is the location of where it is trying to load images?  Are they public resources, or being loaded from an internal/intranet web page.


Can you confirm that you can load these resources using the web browser (connectivity check)?

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Please use plain text.
Contributor
companya
Posts: 10
Registered: ‎01-06-2012
My Device: 9900
My Carrier: rogers

Re: Blackberry 5.0 email can't get images

We can see the images on a 9900. They are public.

Please use plain text.
Contributor
companya
Posts: 10
Registered: ‎01-06-2012
My Device: 9900
My Carrier: rogers

Re: Blackberry 5.0 email can't get images

To clarify, the images are available. We are testing on a 9700 with OS 5.0 (an absolute requirement) but the images show on a 9900 with no issue?

Please use plain text.
BlackBerry Development Advisor (Retired)
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Blackberry 5.0 email can't get images

What format are your images?

 

 

Two different web engines, works with WebKit, doesn't on OS 5.  I believe it could be a transcoding / image format issue.  On 5.0, web assets, like images can be pre-processed by MDS which may result in them not being rendered properly.

 

 

As a test - Is this Corportate email, or public?  If public, can you try disabling your cell radio and enable WiFi?  Would ensure that no transcoding is happening.

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Please use plain text.
Contributor
companya
Posts: 10
Registered: ‎01-06-2012
My Device: 9900
My Carrier: rogers

Re: Blackberry 5.0 email can't get images

  • The images are all jpegs.
  • Also this is the case for any html email with images. We have tested a number of emails not reated by us and we get the same result.
  • We are testing now over wifi.
  • The image "box' shows up with the image title inside but when requested we cannot "get image/s".
Please use plain text.
Contributor
companya
Posts: 10
Registered: ‎01-06-2012
My Device: 9900
My Carrier: rogers

Re: Blackberry 5.0 email can't get images

We are testing over Rogers BIS not BES.

Please use plain text.
Contributor
companya
Posts: 10
Registered: ‎01-06-2012
My Device: 9900
My Carrier: rogers

Re: Blackberry 5.0 email can't get images

I have updated the OS to OS 6 Bundle 2921. Exact same issue.

Any ideas?

Please use plain text.