Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
Philipk
Posts: 676
Registered: ‎05-06-2012
My Device: Dev Alpha & PlayBook

Build and Deploy services not running?

When trying to package my app via Ripple I get the following error...

 

Oh Snap! Build request failded with message: error
This could be due to the Build and Deploy services not running or not being installed

 

What could be causing this? I installed both the SDK and ripple.

_________________________________________________________
co-founder of Diaree | BB Dev for PictureThis
Please use plain text.
Developer
rorybarnes
Posts: 214
Registered: ‎01-07-2011
My Device: Bold 9900

Re: Build and Deploy services not running?

Did you fire up the Command Line program you need running? I believe that is what handles the build and deploy.

 

At a command prompt, start the Ripple service using one of the following:
For Windows, from the C:\Program Files\Research In Motion\Ripple <version>\services\bin directory, type ripple-services.
For Mac OS, from the /Applications/Research In Motion/Ripple <version>/services/bin directory, type ./ripple-services.
The Ripple service starts. You must keep the command prompt or terminal window open while you are using the Ripple emulator.

Source:

Enable the Ripple emulator extension Using the Ripple emulator extension - BlackBerry HTML5/WebWorks http://glpr.ca/Jfa0wA

--
Rory (@roryboy)
Click "Accept as Solution" if post solved your original issue. Give like/thumbs up if you feel post is helpful
Please use plain text.
Contributor
sanshah90
Posts: 36
Registered: ‎06-28-2012
My Device: BB10

Re: Build and Deploy services not running?

ripple-services is not working in Windows7.It shows that it is not an internal or external command.
Please use plain text.
New Contributor
diorefovs
Posts: 3
Registered: ‎04-02-2012
My Device: 9800

Re: Build and Deploy services not running?

谢谢了,thx
Please use plain text.
BlackBerry Development Advisor (Retired)
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Build and Deploy services not running?

The current version of Ripple is BETA and has a manual step you need to run in order to use the build & deploy step.

 

Run the ripple-services.bat file from the following folder C:\Program Files\Research In Motion\Ripple 0.9.5.0\services\bin.

 

Note: Future versions of Ripple will automate this step so you will no longer have to start this process manually. 

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Please use plain text.
New Contributor
supaweb
Posts: 4
Registered: ‎07-23-2012
My Device: Blackberry 9790

Re: Build and Deploy services not running?

could you add this info in documentation at https://developer.blackberry.com/html5/documentation/

hard to start finding this tips.
Please use plain text.
Trusted Contributor
NitishSubudhi
Posts: 166
Registered: ‎12-09-2011
My Device: 9550,9300,9800,9700,9900,9850,9860

Re: Build and Deploy services not running?

Hi Philipk,
I think you are using the older version of Ripple Beta extenction.
Use the "Ripple Emulator (Beta) 0.9.8" 
In this Extenction there is option for Start and Stop Ripple Services. 

Thanks & Regards,
Nitish Subudhi

Feel Free To Press The Like Button On The Right Side To Thank The User That Helped You.
Please Mark Posts As Solved If You Found a Solution.
Please use plain text.
Developer
Levion
Posts: 137
Registered: ‎12-22-2010
My Device: Curve 8520

Re: Build and Deploy services not running?

Where can I find the ripple-service.bat if I install it via extension?

Is the standalone version supported anymore? I can't find a download?

 

Please use plain text.
BlackBerry Development Advisor (Retired)
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Build and Deploy services not running?

The standalone version of Ripple is no longer availalbe.  The latest version of the Ripple Chrome extension has a 'build' panel that allows you to manually start & stop the Ripple services with a single button click.  

 

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Please use plain text.
Developer
Levion
Posts: 137
Registered: ‎12-22-2010
My Device: Curve 8520

Re: Build and Deploy services not running?

Thanks astanley, but I can't find it. Is there some documentation about this feature? Where can I find the service in the extension package?

 

Login - Google Chrome_2012-09-12_15-10-57.png

Please use plain text.