Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
Posts: 20
Registered: ‎01-05-2009
My Device: Not Specified

Can I target BB OS 6 (JRE 6) with WebWorks Eclipse Plugin 2.0

Our WebWorks app was originally built for BB JRE 5.0.0, but we realized we needed a little bit of functionality from 6.0.0 on OS 6 devices devices so I changed the targeted runtime to BlackBerry JRE 6.0.0, but I get a build error on the class library ApplicationFolderIntegrationConfig.

 

Any help would be greatly appreciated!!! Thanks.

Retired
Posts: 518
Registered: ‎07-18-2011
My Device: Bold
My Carrier: Rogers

Re: Can I target BB OS 6 (JRE 6) with WebWorks Eclipse Plugin 2.0

GregSmith:

I'm slightly confused why you're talking about targetted runtimes and JREs when thats all hidden for WebWorks projects in eclipse, but I'll assume you're using the /s option and opening the project with eJDE.

 

If all you want is to compile for 6.0 this can be done much more simply. In your bin folder there's a file bbwp.properties. If you modify the <lib> entry to point to the net.rim.api.jar for 6.0 then you can simply use the sdk as before and everything should work.



1.Please resolve your thread by clicking the "Accept as Solution" button below the post which solved your problem!
2. If any post helps you please click the button below the post(s)
New Developer
Posts: 20
Registered: ‎01-05-2009
My Device: Not Specified

Re: Can I target BB OS 6 (JRE 6) with WebWorks Eclipse Plugin 2.0

Our bbwp.properties file doesn't contain a <lib> property. Would it be something like a path to the BB Component pack for 6.0.0? Like this:

 

<lib>C:\BlackBerryEclipse\BlackBerryEclipse\plugins\net.rim.ejde.componentpack6.0.0_6.0.0.30\components</lib>

 

 

Thanks

New Developer
Posts: 20
Registered: ‎01-05-2009
My Device: Not Specified

Re: Can I target BB OS 6 (JRE 6) with WebWorks Eclipse Plugin 2.0

We're using WebWorks 2.0...I see that there is a 2.1 that doesn't integrate into Eclipse...hopefully that isn't the proglem
Retired
Posts: 518
Registered: ‎07-18-2011
My Device: Bold
My Carrier: Rogers

Re: Can I target BB OS 6 (JRE 6) with WebWorks Eclipse Plugin 2.0

[ Edited ]

If there is no lib property, you can simply re-name (this way you keep the original) the net.rim.api.jar located in the lib folderand copy in the 6.0 version.



1.Please resolve your thread by clicking the "Accept as Solution" button below the post which solved your problem!
2. If any post helps you please click the button below the post(s)