Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
toddersbud
Posts: 3
Registered: ‎07-09-2010
My Device: blah

Can't click links in BB 8830 Simulator

I can load a page just fine, like Google.com, but I can't for the life of me figure out how to interact with links on the page using the simulator. Is there something I'm missing?

Retired
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Can't click links in BB 8830 Simulator

You need to move the browser pointer around using the trackball... you are not able to click on the links with your mouse pointer.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
New Contributor
toddersbud
Posts: 3
Registered: ‎07-09-2010
My Device: blah

Re: Can't click links in BB 8830 Simulator

Yes, I'm aware of that but it doesn't work. I can use the trackball to do any number of other things, but not navigate items on the page. If I load google.com the search field is focused and i can type in there and by hitting enter on my keyboard process and get search results. When I go to the results page the only thing using the trackball does is scroll the page up and down. It does not however do so by selecting elements on the page. If I go back (hitting esc on my keyboard) the search field is no longer focused and I can't select anything on the page. Again, all I can do is move the screen up a few pixels or down to bring the footer in and out of view, not select anything.

 

I tried Google because I figured it must work on this device, but I'm at a loss. I tried a bunch of other sites and had the same problem, cnn.com, etc.

New Contributor
toddersbud
Posts: 3
Registered: ‎07-09-2010
My Device: blah

Re: Can't click links in BB 8830 Simulator

Anybody else have any ideas? I was using VMWare Fusion on my Mac running XP for the virtualization and simulation. I then installed everything on a dell running Vista and have exactly the same problem. I even tried another Curve simulator: the 8350i and had the exact same problem. The screen only scrolls when using the trackball, but doesn't actually select or highlight anything on the page on any site. 

 

What am I missing?