Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
alexchesser
Posts: 9
Registered: ‎01-17-2013
My Device: developer - multi device.
My Carrier: telus
Accepted Solution

Can't find the download / install package for Ripple Services.

I see a lot of posts talking about the fact that I should just "start up and run ripple services" in order to test and debug my phonegap/cordova app.

 

I cannot however for the life of me figure out how to start up the ripple services.

 

It is not in /program files/ripple it isn't in program files/research in motion/ripple

 

I've never seen or downloaded a package specific to ripple.

 

there's nothing called ripple-services.bat in any of the \BlackBerry WebWorks SDK 2.3.1.5 folders.

 

the ripple CRX file does not install in chrome if I drag it on - but I have been able to get it through the chrome webstore.

 

I am hosting the website via APACHE, but none of my plugins are testable in ripple which means I have to run the simulator (slow) or load device (slower) for any debugging... what is worse is I can't debug any of the javascript except in chrome... which means since I can't access any of the plugins (barcode scanner, a home-rolled one written by myself)  I have no idea of what's going on.

 

Can anyone help me find the links to what i am missing?

 

Please use plain text.
Developer
lewellyn
Posts: 110
Registered: ‎10-22-2011
My Device: PlayBook, Bold 9650, Dev Alpha A
My Carrier: Sprint

Re: Can't find the download / install package for Ripple Services.

To install the CRX, you must drag it onto the page at chrome://extensions

Once you do that, you should have a Ripple button to the right of your address bar. Go to the page in question and click the button.

Hopefully that'll get you closer! :smileyhappy:


Is there a helpful or useful post in this thread? Click the thumbs up on it so that other people can find it more easily!
Like this post too! :smileyvery-happy:
Please use plain text.
New Developer
alexchesser
Posts: 9
Registered: ‎01-17-2013
My Device: developer - multi device.
My Carrier: telus

Re: Can't find the download / install package for Ripple Services.

Thanks so much for the response.  I have managed to install the chrome extension via the chrome web store.

 

Clicking the "add to chrome" button at the the link: 

 

https://chrome.google.com/webstore/detail/ripple-emulator-beta/geelfhphabnejjhdalkjhgipohgpdnoc

 

I've even been able to run the emulator to see various blackberry skins around my Cordova application.

 

*HOWEVER* the problem that i am having is that none of my plugins https://github.com/phonegap/phonegap-plugins/tree/master/BlackBerry/BarcodeScanner and one that I've written myself are testable.  

 

Nor is anything involving the SDCARD (that I can tell)

 

Everything that accessses plugin Objects pops up a window that says "I HAZ CHEEZBURGER" and "object not found"

 

I HAZ CHEESEBURGER

 

In my research I've seen pople mentioning that we should be running ripple-services.

 

http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/Ripple-emulator-extension/m-p/18...

 

I'm hoping that if I somehow manage to find the ripple services I will be able to eliminate the "I HAZ CHEEZBURGER" errors.

 

Additionally the "config" options down the right side of my ripple window are all ginving warnings.

 

ripple config options.

 

Can anything fix this?  Should I stop worrying about running the ripple services?  Is there any other environment where I can debug the javascript handling of what returns from the java (phonegap dev)

Please use plain text.
New Developer
alexchesser
Posts: 9
Registered: ‎01-17-2013
My Device: developer - multi device.
My Carrier: telus

Re: Can't find the download / install package for Ripple Services.

[ Edited ]

FYI - I've gone and tried it the way you suggest and no longer see the Cheeseburger error. 

 

it seems that this thread in gihub https://github.com/blackberry/Ripple-UI/issues/489 confirms that manually starting services is no longer required if you install the Ripple emularot from the blackberry site download

 

(I assume as opposed to their webstore version.  these should be clearly labelled if that's true)

 

Seems the ripple emulator direct from RIM has other errors though.  They don't appear when running the webstore version.

 

 

From console.log below:

 

  1. Uncaught TypeError: Object [object Object] has no method 'build' ripple.js:478
    1. (anonymous function)ripple.js:476
    2. (anonymous function)cordova-2.3.0.js:10102
    3. (anonymous function)
       

 

  1. Uncaught TypeError: Object #<Object> has no method 'exec' barcodescanner.js:81
    1. BarcodeScanner.scanbarcodescanner.js:81
    2. app.scanindex.js:100
    3. v.event.dispatchfoundation.min.js:19

 

cordova :: Your application does not appear to match the platform you have selected. The version number in your configuration might not match the selected platform version or your configuration file has errors in it. ripple.js:475

 

Viewport target-densitydpi is not supported.

 

  1. Uncaught TypeError: Object [object Object] has no method 'build' ripple.js:478
    1. (anonymous function)ripple.js:476
    2. (anonymous function)cordova-2.3.0.js:10102
    3. (anonymous function)
       

 

Please use plain text.
New Developer
alexchesser
Posts: 9
Registered: ‎01-17-2013
My Device: developer - multi device.
My Carrier: telus

Re: Can't find the download / install package for Ripple Services.

OK - more info here:

 

Appears that the Ripple services option does not appear as a possibility if you do not have the "ripplesites" folder as requested here:  

 

https://developer.blackberry.com/html5/documentation/accessing_a_local_project_in_ripple_1948645_11....

 

Still having the error: Uncaught TypeError: Object [object Object] has no method 'build'  but feel like I'm making forward progress. 

 

Will try re-running against the default cordova app instead of on that *may* jhave bugs in it from my own dev.

Please use plain text.
Developer
neemliu
Posts: 40
Registered: ‎07-19-2013
My Device: BlackBerry 9790, 9800, Playbook
My Carrier: TELUS

Re: Can't find the download / install package for Ripple Services.

this site is sooooo quite.......problem still....

Please use plain text.