Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Developer
mbenge
Posts: 21
Registered: ‎03-28-2011
My Device: Style 9670
My Carrier: Sprint

Cannot install WebWorks Plugin via Eclipse update site

When I attempt to install the WebWorks plugin, I am prompted for my developer zone userid and password.  I am entering the correct information, but I am prompted multiple times until the maximum access attempts are exceeded.  I can log into the developer zone via a browser. What could be causing this issue?  It was working yesterday. 

 

BlackBerry WebWorks Plug-in Update Site - http://www.blackberry.com/go/eclipseUpdate/3.6/web

 

Thanks,

Mark

Please use plain text.
New Contributor
awysocki
Posts: 4
Registered: ‎05-17-2010
My Device: Simulator Bold 9700
My Carrier: None

Re: Cannot install WebWorks Plugin via Eclipse update site

I Too am having this problem.  I created a new Development ID and tried that, but nothing works I just get the following errors. Yet when I put the URL into my browser, I'm prompted for my user/pass if I key it in, I get the JAR file.  Yet I can't get this to work from within the BlackBerry Eclipse environment I installed directly from their install package

 

An error occurred while collecting items to be installed
session context was:smileysad:profile=SDKProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Unable to read repository at: https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA... Too many failed login attempts.
Unable to read repository at: https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA... Too many failed login attempts.
Unable to read repository at: https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA... Too many failed login attempts.
Unable to read repository at: https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA... Too many failed login attempts.
Unable to read repository at: https://www.blackberry.com/Downloads/auth/contactFormPreload.do?code=DC727151E5D55DDE1E950767CF861CA... Too many failed login attempts.

Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Cannot install WebWorks Plugin via Eclipse update site

We have had consistent problems with Eclipse Update sites for full installations of products.  We have recently removed this option for Java developers and we will also be removing the option for full installations via the update site for Web developers.

 

I would suggest that you download and install the full installer for the Web Plug-in which will install eclipse and all needed requirements and dependencies.

 

http://us.blackberry.com/developers/browserdev/eclipseplugin.jsp

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
Developer
mbenge
Posts: 21
Registered: ‎03-28-2011
My Device: Style 9670
My Carrier: Sprint

Re: Cannot install WebWorks Plugin via Eclipse update site

Hey Tim,

   Thanks for your response.  I am looking for a way to have both the WebWorks and JDE available under the same Rational Team Concert (RTC) / Eclipse based environment. Initially I took the following approach:

 

1) Installed Sun JDK6 update 24

2) Installed Eclipse Helios, RTC, and WTP (needed for WebWorks)

3) Installed WebWorks Plugin/SDK via Eclipse update site

 

Note:  RTC installation included EMF.

 

I was able to build a simple WebWorks app and successfully deploy it to the Torch simuator.

 

While investigating JavaScript extensions I found the following article that recommended using the BlackBerry JDE:  http://supportforums.blackberry.com/t5/Web-Development/Building-a-BlackBerry-WebWorks-JavaScript-Ext...

 

I discovered that the JDE was available via the Eclipse update site, but at the time I did not realize that it did not include the plugin.  I was able to install the component on Monday (3/28).  When I discovered that the plugin was not included, I downloaded the full installer for the Java environment, and performed the installation into a new folder.  Afterwards, I used the following steps to set up a new environment:

 

1) Installed RTC and WTP

2) Attempted to install WebWorks Plugin/SDK via Eclipse update site.

 

The installation failed as I previously noted.  Here are trace statements from the Eclipse log, noting retry attempts as I was presented the login dialog:

 

!ENTRY org.apache.commons.httpclient.auth.AuthChallengeProcessor 1 800 2011-03-30 16:02:44.453
!MESSAGE basic authentication scheme selected

 

!ENTRY org.apache.commons.httpclient.HttpMethodDirector 1 800 2011-03-30 16:02:44.453
!MESSAGE No credentials available for BASIC 'Please enter your BlackBerry Developer Zone ID and Password'@swdownloads.blackberry.com:443

 

!ENTRY org.apache.commons.httpclient.auth.AuthChallengeProcessor 1 800 2011-03-30 16:02:44.468
!MESSAGE basic authentication scheme selected

 

!ENTRY org.apache.commons.httpclient.HttpMethodDirector 1 800 2011-03-30 16:02:44.468
!MESSAGE No credentials available for BASIC 'Please enter your BlackBerry Developer Zone ID and Password'@swdownloads.blackberry.com:443

 

As a test, I reverted to my older installation to determine if I could install the JDE component via the Eclipse update.  This failed in the same manner.  Could this be a timeout issue?  I did note that the browser based login into the developer zone was taking an inordinately long period of time.

 

Thanks,

Mark

Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,708
Registered: ‎10-16-2008
My Device: Z10
My Carrier: Rogers

Re: Cannot install WebWorks Plugin via Eclipse update site

Hi Mark,

 

The issues you are pointing out are some of the reasons why we are moving away from Eclipse Update sites.  There are many different moving parts that all have to come together to make a successful install.  Combining that with the need for username and password, and https downloads from our site makes it a definate challenge.

 

I understand that you would like to have both tools in the same instance of Eclipse but it is going to be a challenge to get there with the issues you're experiencing with the update site.

 

I would recommend that you install them into separate environments using the full installers.  While it isn't the desired approach that you would like, it is the one that I'm confident will work.

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
New Contributor
Hadas_Mobile
Posts: 3
Registered: ‎07-17-2011
My Device: Torch 9800
My Carrier: Mobile Software Engineer

Re: Cannot install WebWorks Plugin via Eclipse update site

I try to install 



  1. Start Eclipse and create a workspace.
  2. Help -> Install New Software... -> Click Add...
    Name: Blackberry Update - Web
    Location: Blackberry Web -http://www.blackberry.com/go/eclipseUpdate/3.6/web
  3. Select Blackberry Web Plug-in Category.  This will select both of the required plug-ins

but I get pop up with request to username and password.

where can I get them?

Please use plain text.
BlackBerry Development Advisor (Retired)
jeffheifetz
Posts: 518
Registered: ‎07-18-2011
My Device: Bold
My Carrier: Rogers

Re: Cannot install WebWorks Plugin via Eclipse update site

Hadas_Mobile - this should be your BlackBerry Developer username and password



1.Please resolve your thread by clicking the "Accept as Solution" button below the post which solved your problem!
2. If any post helps you please click the button below the post(s)
Please use plain text.
New Contributor
cissemy
Posts: 2
Registered: ‎06-09-2009
My Device: Not Specified

Re: Cannot install WebWorks Plugin via Eclipse update site

Hi,

I am not able to  install WebWorks Plugin via Eclipse update site.

How can I install webworks Plugin manually ?

I did download webworks WebWorks-BB-Win-v2.2.exe ,how can i plugin it in eclipse environment ?

 

Thanks,

 

Please use plain text.
BlackBerry Development Advisor (Retired)
jeffheifetz
Posts: 518
Registered: ‎07-18-2011
My Device: Bold
My Carrier: Rogers

Re: Cannot install WebWorks Plugin via Eclipse update site

Hi cissemy,

 

The eclipse plugin is no longer supported but this doesn't mean you can't still use eclipse. You can use eclipse with the WTP to do all of your web development and configure an external tool to call bbwp.



1.Please resolve your thread by clicking the "Accept as Solution" button below the post which solved your problem!
2. If any post helps you please click the button below the post(s)
Please use plain text.