Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
BBZKING
Posts: 4
Registered: ‎01-11-2011
My Carrier: Rogers
Accepted Solution

Cannot install sketchPad sample app on Playbook simulator

I tied to install the sample sketchPad from (http://supportforums.blackberry.com/t5/Web-Development/Sample-Code-SketchPad-Application/ta-p/614077... to the Playbook Simulator.

It compiles fine to the .bar file, but it failed as I used deploy command to install it.

 

It will be really appreciated if anyone can help.

 

Thanks

 

 

 

 

Following are the command I used to package the app, which works fine,

 

"C:\BlackBerry WebWorks Packager for PlayBook\bbwp\bbwp.exe" "sketchPad.zip" /o "." /d /v
[INFO]                  Parsing command line options
[INFO]                  Parsing bbwp.properties
[INFO]                  Validating WebWorks archive
[INFO]                  Parsing config.xml
[INFO]                  Validating config.xml
[INFO]                  Validating application version
[WARNING]               Failed to find a <feature> element
[INFO]                  Validating the <name> element
[INFO]                  Validating the <author> element
[INFO]                  Populating application source
[INFO]                  Compiling WebWorks application
Loading configuration file C:\BlackBerry WebWorks Packager for PlayBook\bbwp\blackberry-tablet-sdk\frameworks\air-config.xml
...\AppData\Local\Temp\widgetGen.793960361296187249787.tmp\sketchPad.swf (26704 bytes)
[INFO]                  Packaging the bar file
[INFO]                  Bar packaging complete
[INFO]                  WebWorks application packaging complete

 

 

Following is the command I used to install, and it failed to install.

 

 

"c:\BlackBerry WebWorks Packager for PlayBook\bbwp\blackberry-tablet-sdk\bin\blackberry-deploy" -installApp  -device 192.168.131.130 -package "sketchPad.bar"


Sending Install request...
Action: Install
File size: 38950
Installing ...
actual_dname::
actual_id::
actual_version::
result::failure

 

BTW, everything works fine when I tried to install a flashair app to it using flashAir playbook SDK.

Please use plain text.
Contributor
Brigante
Posts: 20
Registered: ‎04-29-2010
My Carrier: O2

Re: Cannot install sketchPad sample app on Playbook simulator

You need to include your device password when you deploy the app to the simulator.

 

 

blackberry-deploy -installApp -password YourDevicePassword -device xx.xx.xx.xx -package path\to\appname.bar

 

It should work with the above command.

 

Please use plain text.
New Contributor
BBZKING
Posts: 4
Registered: ‎01-11-2011
My Carrier: Rogers

Re: Cannot install sketchPad sample app on Playbook simulator

I did try witht he password again, but got the same error. Not sure if anyone accountered the same issue.

 

"C:\BlackBerry WebWorks Packager for PlayBook\bbwp\blackberry-tablet-sdk\bin\blackberry-deploy" -password a  -installApp -device 192.168.131.130 -package "sketchPad.bar"
Sending Install request...
Action: Install
File size: 38950
Installing ...
actual_dname::
actual_id::
actual_version::
result::failure

Please use plain text.
Developer
jmace
Posts: 482
Registered: ‎10-24-2008
My Carrier: AT&T

Re: Cannot install sketchPad sample app on Playbook simulator

I'm also having the same issue and getting to the point of deployment with a failure.

 

here's the batch file i'm running below.

 

 

:: J. Mace 2010

CLS
:: Remove old widget archive
ECHO Y | DEL "C:\Program Files\Research In Motion\BlackBerry WebWorks Packager for PlayBook\bbwp\Sketchpad.zip"

:: Copy project to a temp directory
XCOPY "C:\Users\Mace\Documents\Visual Studio 2008\Projects\Sketchpad" "C:\temp\Sketchpad" /E /y

PAUSE
:: Zip latest widget files and move to the widget packager directory
"C:\Program Files\7-Zip\7z.exe" a "C:\Program Files\Research In Motion\BlackBerry WebWorks Packager for PlayBook\bbwp\Sketchpad.zip"  "C:\temp\Sketchpad\*"
:: Run the widget packager
cd "C:\Program Files\Research In Motion\BlackBerry WebWorks Packager for PlayBook\bbwp\"

:: ------- TEST -------
bbwp.exe Sketchpad.zip

PAUSE
blackberry-deploy -installApp -password 123password -device 192.168.61.128 -package "C:\Program Files\Research In Motion\BlackBerry WebWorks Packager for PlayBook\bbwp\bin\Sketchpad.bar"
PAUSE

 

I have two breaks around the blackberry-deploy, but my command line window disappears before I can get a screenshot of the full error. I've checked the password as well as the IP and directory of the .bar file to no avail.

 

_________________________________________
www.jasonmace.com/blackberry
Please use plain text.
Contributor
Brigante
Posts: 20
Registered: ‎04-29-2010
My Carrier: O2

Re: Cannot install sketchPad sample app on Playbook simulator

@jmace

 

I've just tested your batch file and it's working perfectly fine on my setup. No errors.

 

Have you tried to reinstall the simulator? I had to install and uninstall 3 times before I got mine working. Not the same issue but worth a try maybe.

Please use plain text.
Developer
jmace
Posts: 482
Registered: ‎10-24-2008
My Carrier: AT&T

Re: Cannot install sketchPad sample app on Playbook simulator

[ Edited ]

Thanks Brigante for taking a glance at that.

 

I've uninstalled and installed the Playbook SDK as well as the simulator. Now I am getting a message that the blackberry-deploy is "not an internal or recognized command" , which tells me the environment variable PATH doesn't contain the right path to the batch file. I went in and added 

 

C:\Program Files\Research In Motion\BlackBerry WebWorks Packager for PlayBook\bbwp\blackberry-tablet-sdk\bin\

 

to my environment variable, but I'm still getting the unrecognized command message... throwing me for a loop now... anyone run into a similar situation?

 

 

* Edit

 

I've just added the complete path to the blackberry-deploy call, but I'm getting an "out of sync" message in the command prompt that disappears before I can read it. 

_________________________________________
www.jasonmace.com/blackberry
Please use plain text.
Contributor
Brigante
Posts: 20
Registered: ‎04-29-2010
My Carrier: O2

Re: Cannot install sketchPad sample app on Playbook simulator

This is the path I have in my environment variable:

 

C:\Program Files\Blackberry Tablet OS SDK\blackberry-tablet-sdk-0.9.2\bin;C:\Program Files\Blackberry Tablet OS SDK\WebWorks SDK\bbwp\

 

Sounds like you probably have one of those small really annoying errors somewhere that is really really obvious once you find it :smileyhappy:

 

 

Please use plain text.
Administrator
astanley
Posts: 1,359
Registered: ‎07-02-2009
My Carrier: Bell

Re: Cannot install sketchPad sample app on Playbook simulator

Is the version of the simulator being used the same as that of the Tablet OS SDK?

 

It should be version 0.9.2 for both.  If either are out of sync, I might expect to see a similar 'failure' message.  BlackBerryPlayBookSimulator-0.9.2.iso

 

Another scenario to be considerate of is ensuring that the system time of the Tablet OS is the same as that of your host PC.  

 

 

Try running the following to see if you see any apps that might be conflicting with your install?

 

 

blackberry-deploy -listInstalledApps -device <ipaddress> -password <password>

 

 

 

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Please use plain text.
Developer
jmace
Posts: 482
Registered: ‎10-24-2008
My Carrier: AT&T

Re: Cannot install sketchPad sample app on Playbook simulator

I had to synchronize the clock with my PC...you were right Brigante, it was something small...

 

Thanks Adam for the ideas. 

_________________________________________
www.jasonmace.com/blackberry
Please use plain text.
New Contributor
BBZKING
Posts: 4
Registered: ‎01-11-2011
My Carrier: Rogers

Re: Cannot install sketchPad sample app on Playbook simulator

It worked after reinstall the simulator. I guess some how the simulator was upgraded since my last download.

 

Thanks

Please use plain text.