Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
Posts: 2
Registered: ‎10-10-2012
My Device: BB10 Alpha
My Carrier: --
Accepted Solution

Cannot package App when updated to webworks 1.0.2.9

I could package app within Ripple with webworks 1.0.0.17, but failed to package when upgrade to 1.0.2.9.

Got error msg as below. Hope somebody can help. Thanks.

 

i'm using win7 64bit, java 1.6e 64bit installed, ripple v0.9.10.

 

Is it becuase of Java veriosn?

 

=====================

out:
C:\Users\feng75\AppData\Local\Google\Chrome\User Data\Default\Extensions\cnijnna
imeaacneklcndcafbnkeicckh\0.9.10_1\services\node\node_modules\rbd>"C:\Program Fi
les\Research In Motion\BlackBerry 10 WebWorks SDK 1.0.2.9\dependencies\node\node
.exe" "C:\Program Files\Research In Motion\BlackBerry 10 WebWorks SDK 1.0.2.9\li
b\bbwp.js" "C:\BBProj\output/iLoveCook.zip" -o "C:\BBProj\output" -d

2012-10-09 17:05:26 GET /ripple/build_status/3993 200
2012-10-09 17:05:27 GET /ripple/build_status/3993 200
2012-10-09 17:05:27 GET /ripple/build_status/3993 200
2012-10-09 17:05:28 GET /ripple/build_status/3993 200
2012-10-09 17:05:28 GET /ripple/build_status/3993 200
2012-10-09 17:05:29 GET /ripple/build_status/3993 200
2012-10-09 17:05:29 GET /ripple/build_status/3993 200
2012-10-09 17:05:30 GET /ripple/build_status/3993 200
out: [INFO] Populating application source

2012-10-09 17:05:30 GET /ripple/build_status/3993 200
2012-10-09 17:05:31 GET /ripple/build_status/3993 200
2012-10-09 17:05:31 GET /ripple/build_status/3993 200
2012-10-09 17:05:32 GET /ripple/build_status/3993 200
2012-10-09 17:05:32 GET /ripple/build_status/3993 200
2012-10-09 17:05:33 GET /ripple/build_status/3993 200
2012-10-09 17:05:33 GET /ripple/build_status/3993 200
2012-10-09 17:05:34 GET /ripple/build_status/3993 200
2012-10-09 17:05:34 GET /ripple/build_status/3993 200
2012-10-09 17:05:35 GET /ripple/build_status/3993 200
out: [INFO] Parsing config.xml

out: [WARN] Build ID set in config.xml [version], but signing key file was no
t found: author.p12

out: [WARN] Build ID set in config.xml [version], but no signing password was
provided [-g]. Bar will be unsigned

out: [WARN] Failed to find feature with id: blackberry.message.sms

out: [WARN] Failed to find feature with id: blackberry.ui.menu

out: [WARN] Failed to find feature with id: blackberry.system.event

out: [WARN] Failed to find feature with id: blackberry.app.event

out: [INFO] Generating output files

out: [WARN] Failed to find debug token

2012-10-09 17:05:35 GET /ripple/build_status/3993 200
2012-10-09 17:05:36 GET /ripple/build_status/3993 200
2012-10-09 17:05:36 GET /ripple/build_status/3993 200
2012-10-09 17:05:37 GET /ripple/build_status/3993 200
2012-10-09 17:05:37 GET /ripple/build_status/3993 200
2012-10-09 17:05:38 GET /ripple/build_status/3993 200
out: [ERROR] java.lang.UnsupportedClassVersionError: com/qnx/bbt/nativepackage
r/BarNativePackager (Unsupported major.minor version 50.0)

out: [INFO] at java.lang.ClassLoader.defineClass0(Native Method) at java.
lang.ClassLoader.defineClass(Unknown Source) at java.security.SecureClassLoad
er.defineClass(Unknown Source) at java.net.URLClassLoader.defineClass(Unknown S
ource) at java.net.URLClassLoader.access$100(Unknown Source) at java.net.URLC
lassLoader$1.run(Unknown Source) at java.security.AccessController.doPriv
ileged(Native Method) at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source) at sun.misc.Launcher$App
ClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unkno
wn Source)

out: [INFO] at java.lang.ClassLoader.loadClassInternal(Unknown Source)

2012-10-09 17:05:38 GET /ripple/build_status/3993 200
out: [INFO] Exception in thread "main"

out: [ERROR] Native Packager exception occurred

2012-10-09 17:05:39 GET /ripple/build_status/3993 200
out: [WARN] Failed to find debug token

2012-10-09 17:05:39 GET /ripple/build_status/3993 200
out: [ERROR] java.lang.UnsupportedClassVersionError: com/qnx/bbt/nativepackage
r/BarNativePackager (Unsupported major.minor version 50.0)

out: [INFO] at java.lang.ClassLoader.defineClass0(Native Method) at java.
lang.ClassLoader.defineClass(Unknown Source)

out: [INFO] at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source) at java.net.URLClassLoad
er.access$100(Unknown Source) at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method) at java.
net.URLClassLoader.findClass(Unknown Source) at java.lang.ClassLoader.loadCla
ss(Unknown Source) at sun.misc.Launcher$AppClassLoader.loadClass(Unknown So
urce) at java.lang.ClassLoader.loadClass(Unknown Source) at java.lang.Cla
ssLoader.loadClassInternal(Unknown Source)

out: [INFO] Exception in thread "main"

out: [ERROR] Native Packager exception occurred

2012-10-09 17:05:40 GET /ripple/build_status/3993 200
Done build
error response - {"code":1,"msg":"[ERROR] java.lang.UnsupportedClassVersionErr
or: com/qnx/bbt/nativepackager/BarNativePackager (Unsupported major.minor versio
n 50.0)\n[INFO] \tat java.lang.ClassLoader.defineClass0(Native Method)\tat ja
va.lang.ClassLoader.defineClass(Unknown Source)\tat java.security.SecureClassLoa
der.defineClass(Unknown Source)\tat java.net.URLClassLoader.defineClass(Unknown
Source)\tat java.net.URLClassLoader.access$100(Unknown Source)\tat java.net.URLC
lassLoader$1.run(Unknown Source)\tat java.security.AccessController.doPrivileged
(Native Method)\tat java.net.URLClassLoader.findClass(Unknown Source)\tat java.l
ang.ClassLoader.loadClass(Unknown Source)\tat sun.misc.Launcher$AppClassLoader.l
oadClass(Unknown Source)\tat java.lang.ClassLoader.loadClass(Unknown Source)\n[I
NFO] \tat java.lang.ClassLoader.loadClassInternal(Unknown Source)\n[INFO]
Exception in thread \"main\" \n[ERROR] Native Packager exception occurred\n[WA
RN] Failed to find debug token\n[ERROR] java.lang.UnsupportedClassVersionEr
ror: com/qnx/bbt/nativepackager/BarNativePackager (Unsupported major.minor versi
on 50.0)\n[INFO] \tat java.lang.ClassLoader.defineClass0(Native Method)\tat j
ava.lang.ClassLoader.defineClass(Unknown Source)\n[INFO] \tat java.security.S
ecureClassLoader.defineClass(Unknown Source)\tat java.net.URLClassLoader.defineC
lass(Unknown Source)\tat java.net.URLClassLoader.access$100(Unknown Source)\tat
java.net.URLClassLoader$1.run(Unknown Source)\tat java.security.AccessController
.doPrivileged(Native Method)\tat java.net.URLClassLoader.findClass(Unknown Sourc
e)\tat java.lang.ClassLoader.loadClass(Unknown Source)\tat sun.misc.Launcher$App
ClassLoader.loadClass(Unknown Source)\tat java.lang.ClassLoader.loadClass(Unknow
n Source)\tat java.lang.ClassLoader.loadClassInternal(Unknown Source)\n[INFO]
Exception in thread \"main\" \n[ERROR] Native Packager exception occurred\n",
"data":null}
2012-10-09 17:05:40 GET /ripple/build_status/3993 200

==================

Developer
Posts: 466
Registered: ‎04-11-2012
My Device: Bold 9900
My Carrier: Rogers

Re: Cannot package App when updated to webworks 1.0.2.9

I believe there are some changes in the latest version of webworks that you may need to adjust your app for it to work. I believe there is a session on this tomorrow at 11 am and 2 pm EST for more info go here >> http://www.blackberrydeveloperevents.com/events/home.html


Developer for easyDial for BlackBerry Bold & inLink for BlackBerry PlayBook
Find me online via twitter, or on the techfruits.com webpage. Please hit the like button below if what I said helped!
New Contributor
Posts: 2
Registered: ‎10-10-2012
My Device: BB10 Alpha
My Carrier: --

Re: Cannot package App when updated to webworks 1.0.2.9

solved. updated JRE (win32) to 1.6 then everything is fine.

New Developer
Posts: 15
Registered: ‎05-10-2009
My Device: Not Specified

Re: Cannot package App when updated to webworks 1.0.2.9

Same issue.
Running Java 7 Update 9 on Vista-32 here.
Any hope?
MarkT