Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
jian
Posts: 33
Registered: ‎08-29-2008
My Device: Not Specified
Accepted Solution

Cannot start Ripple Services

I downloaded the latest ripple_ui.crx,  then opened Google Chrome browser and went to Tools > Extensions, then dragged ripple_ui.crx into the Google Chrome Extensions window, and added the extension.

 

When I clicked the "Start Ripple Services":

 

node.js:205
        throw e; // process.nextTick error, or 'error' event on first tick
              ^
Error: Cannot find module 'delayed-stream'
    at Function._resolveFilename (module.js:318:11)
    at Function._load (module.js:263:25)
    at Module.require (module.js:341:17)
    at require (module.js:352:17)
    at Object.<anonymous> (C:\Users\myComputer\AppData\Local\Google\Chrome\User Data\D
efault\Extensions\cnijnnaimeaacneklcndcafbnkeicckh\0.9.15_0\services\node\node_m
odules\ripple-emulator\node_modules\request\node_modules\form-data\node_modules\
combined-stream\lib\combined_stream.js:3:21)
    at Module._compile (module.js:416:26)
    at Object..js (module.js:434:10)
    at Module.load (module.js:335:31)
    at Function._load (module.js:294:12)
    at Module.require (module.js:341:17)

Please use plain text.
Retired
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Cannot start Ripple Services

This is a known issue that our dev teams are actively working today on fixing ASAP.  

 

https://github.com/blackberry/Ripple-UI/issues/750

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
Please use plain text.
New Developer
jian
Posts: 33
Registered: ‎08-29-2008
My Device: Not Specified

Re: Cannot start Ripple Services

The patch does not work for me. I wonder when the new release is available and is it possible to get the previous version to use while we wait for the fix?

Please use plain text.
Developer
poornamelessme
Posts: 173
Registered: ‎12-10-2012
My Device: Dev Alpha C

Re: Cannot start Ripple Services

Same happened to me. I noticed Ripple seemed to update itself, which is more like a downgrade, as now I can't use it at all.

Please use plain text.
Regular Contributor
iruka
Posts: 79
Registered: ‎09-17-2012
My Device: Torch 9800

Re: Cannot start Ripple Services

I have this problem as well and have problems packing my app. If you need to package your app, try to package using the BB Webworks SDK.

 

Package your smartphone app with the BlackBerry WebWorks SDK

 

 

Please use plain text.
Contributor
hkao
Posts: 10
Registered: ‎12-09-2012
My Device: BB10

Re: Cannot start Ripple Services

I got the same problem.  It seems this problem is only happening with version  0.9.15.  I deleted this version and install the previous one 0.9.14.  It seems to be working fine.  I have a copy of version 0.9.14.  PM me if you need a copy.

Please use plain text.
Contributor
TechMark2K
Posts: 12
Registered: ‎03-05-2013
My Device: PlayBook

Re: Cannot start Ripple Services

Please use plain text.
Developer
srk2012
Posts: 672
Registered: ‎12-04-2012
My Device: BlackBerry 8520

Re: Cannot start Ripple Services

Again iams eeing the previous error message when trying to build and package the application on the ripple

 

 

 

 


node.js:205
throw e; // process.nextTick error, or 'error' event on first tick
^
Error: Cannot find module 'delayed-stream'
at Function._resolveFilename (module.js:318:11)
at Function._load (module.js:263:25)
at Module.require (module.js:341:17)
at require (module.js:352:17)
at Object.<anonymous> (C:\Users\Sravan\AppData\Local\Google\Chrome\User Data
\Default\Extensions\cnijnnaimeaacneklcndcafbnkeicckh\0.9.15_0\services\node\node
_modules\ripple-emulator\node_modules\request\node_modules\form-data\node_module
s\combined-stream\lib\combined_stream.js:3:21)
at Module._compile (module.js:416:26)
at Object..js (module.js:434:10)
at Module.load (module.js:335:31)
at Function._load (module.js:294:12)
at Module.require (module.js:341:17)

C:\Program Files\Google\Chrome\Application\26.0.1410.64>

 

 

 

 

Please give one ideal solution so that I can build  properly.

 

 

 

Please use plain text.