Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
Wongadob
Posts: 40
Registered: ‎05-12-2012
My Device: 9800
My Carrier: Virgin mobile

Cant get images to cache

This is the final part of a previous entry, but I have put it here incase anybody gets scared off the complexity of the first issue. I created a super simplified test harness to try and resolve my caching issue, but it still have the same problem. This is SUPER urgent for a project I am working on. Please can som,ebody put me out of my misery!!

 

 Here is the entire site HTML

 

<!DOCTYPE html>
<html>
<head>
   <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
   <meta name="viewport" id="viewport" content="target-densitydpi=high-dpi,initial-scale=1.0,user-scalable=no,minimum-scale=1.0,maximum-scale=1.0" />
   <title>Test Harness</title>
</head>

<body id="bodyID" >
	<div>
		<img src='art/no_photo_small.gif'/>
		<img src='art/no_photo_small.gif'/>
		<img src='art/no_photo_small.gif'/>
		<img src='art/no_photo_small.gif'/>
		<img src='art/no_photo_small.gif'/>
		<img src='art/no_photo_small.gif'/>
		<img src='art/no_photo_small.gif'/>
	</div>
</body>

</html>

And the following config file

 

<?xml version="1.0" encoding="UTF-8"?>
<widget xmlns="http://www.w3.org/ns/widgets" 
   	xmlns:rim="http://www.blackberry.com/ns/widgets" 


   	version="1.0.0.816" rim:header="Test Harness">

   	<name>Harness</name>
   	<description>Testing App.</description>
   	<content src="index.html"/>
   	<access uri="*" subdomains="true"/>

	<rim:cache maxCacheSizeTotal="2048" maxCacheSizeItem ="256" />

   	<rim:navigation mode="focus" />
    <icon src="blackberry_128test.png" />
   
   	<feature id="blackberry.app" required="true" version="1.0.0.0"/>
   	<feature id="blackberry.system"/>   	
   	<feature id="blackberry.system.event"/>
   	<feature id="blackberry.ui.dialog" />
   	<feature id="blackberry.ui.menu" required="true" version="1.0.0.0" />
   	<feature id="blackberry.invoke" /> 
   	<feature id="blackberry.invoke.MessageArguments" />
   	<feature id="blackberry.invoke.BrowserArguments" /> 
   	<feature id="blackberry.message" />

</widget>

 

This is not caching the image files. WHY what am I doing wrong. This is super urgent!!!!

Please use plain text.