Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
MorganLeecy
Posts: 3
Registered: ‎02-07-2013
My Device: Z10

Cant start Build Services (MAC 10.8.2 / Ripple 0.9.13)

I am running Ripple on Chrome on MacOS (latest

 

Ripple Version 0.9.13

Java - Mac Version as per BB instructions

Latest SDK installed in default location

/Developer/SDKs/Research In Motion/BlackBerry 10 WebWorks SDK 1.0.4.7

Allow file access for ripple ticked in extension manager

 

I cannot start build services. Clicking on the button does nothing, just sits there looking dumb,

 

Any advice from other mac owners would be appreciated.

Developer
JRab
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: Cant start Build Services (MAC 10.8.2 / Ripple 0.9.13)

Hey MorganLeecy,

 

Try restarting your browser (if you haven't already done so). When you do it should open up a Terminal screen that shows the service is running -- it's going to look like a Windows Command Prompt. Good luck!

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
New Contributor
MorganLeecy
Posts: 3
Registered: ‎02-07-2013
My Device: Z10

Re: Cant start Build Services (MAC 10.8.2 / Ripple 0.9.13)

Well installing Ripple from Chrome store does not work..

Trying to install from the CRX file on BB webage result in Chrome not allowing it anymore..

 

So I had to (amazingly enough), unpack the CRX from Blackberry Website, unzip it, and install in developer mode. When I start Ripple now, its looks completely different, with checkbox for auto starting build services etc.

 

Looks completely different, and build services now start.. yeah, I still cant build apps as the error message is the same, but Ripple now reckons Buildservices are running so a step in the rght direction

Developer
JRab
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: Cant start Build Services (MAC 10.8.2 / Ripple 0.9.13)

The way I ususally install the Extension is by first going and downloading hte CRX file from BlackBerry and then open up the Extension panel in Chrome (Tools > Extensions). Then drag the CRX file I just downloaded into the Extension window and it confirms then installs the Extension properly.

 

Try uninstalling ur extension and trying the above method to see if you get simliar results. Good luck!

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
New Contributor
MorganLeecy
Posts: 3
Registered: ‎02-07-2013
My Device: Z10

Re: Cant start Build Services (MAC 10.8.2 / Ripple 0.9.13)

Tried that, get a popup from chrome stating that installs direct from that website.. Ie blackberry.. are no longer allowed, and I must use the google App Store.. Or whatever it's called
Contributor
rg_bb
Posts: 21
Registered: ‎04-25-2012
My Device: 9800

Re: Cant start Build Services (MAC 10.8.2 / Ripple 0.9.13)

Did you ever get a solution to this?

 

I am used to using Ripple on PC, but not so familiar with Macs in general and having the same problem. Using OSX 10.7.5, Ripple for Chrome 0.9.15 and have Blackberry SDK installed in default location.

 I have set my SDK PATH to:

/Developer/SDKs/Research In Motion/BlackBerry WebWorks SDK 2.3.1.5

but nothing happens

Contributor
rg_bb
Posts: 21
Registered: ‎04-25-2012
My Device: 9800

Re: Cant start Build Services (MAC 10.8.2 / Ripple 0.9.13)

Using RIpple 0.9.14 (from Blackberry direct), as opposed to 0.9.15 (from Chrome Store) seems to be working for me.

New Contributor
jwloach
Posts: 4
Registered: ‎04-20-2011
My Device: Z10

Re: Cant start Build Services (MAC 10.8.2 / Ripple 0.9.13)

Hi!

 

I'm having the same problem after the auto-update to 0.9.15. Where did you find 0.9.14 on the BB site? It would be great to get it back!

 

Thank you.

Contributor
rg_bb
Posts: 21
Registered: ‎04-25-2012
My Device: 9800

Re: Cant start Build Services (MAC 10.8.2 / Ripple 0.9.13)

[ Edited ]

It seems to me, when you download Ripple from Blackberry, it still auto-updates from the main 'Chrome' branch. Everytime chrome updates ripple you will have a version that doesn't work. You need to go back to the Blackberry Ripple download page

https://developer.blackberry.com/html5/download/#smartphones

and download the version of the Chrome extension that is up there.

 

This is what I did today, and everything is working again...

New Contributor
jwloach
Posts: 4
Registered: ‎04-20-2011
My Device: Z10

Re: Cant start Build Services (MAC 10.8.2 / Ripple 0.9.13)

I just tried that again, and the same result. Here's the contents of the 'Start B&D' console that opens. I tried reinstalling the Java JDK as well, but no better. The 'delayed-stream' module seems to be present.

 

Thank you! John


node.js:205
throw e; // process.nextTick error, or 'error' event on first tick
^
Error: Cannot find module 'delayed-stream'
at Function._resolveFilename (module.js:318:11)
at Function._load (module.js:263:25)
at Module.require (module.js:341:17)
at require (module.js:352:17)
at Object.<anonymous> (C:\Users\John\AppData\Local\Google\Chrome\User Data\D
efault\Extensions\cnijnnaimeaacneklcndcafbnkeicckh\0.9.15_0\services\node\node_m
odules\ripple-emulator\node_modules\request\node_modules\form-data\node_modules\
combined-stream\lib\combined_stream.js:3:21)
at Module._compile (module.js:416:26)
at Object..js (module.js:434:10)
at Module.load (module.js:335:31)
at Function._load (module.js:294:12)
at Module.require (module.js:341:17)

C:\Program Files (x86)\Google\Chrome\Application\26.0.1410.43>