Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Contributor
Gnof
Posts: 4
Registered: ‎11-24-2012
My Device: Dev Alpha
Accepted Solution

Error: Failed to create application process: Operation not permitted -- Deploying from Ripple to Dev Alpha

[ Edited ]

Hey folks,

 

I've been stumped on this for the last little while and can't seem to find a solution. (The closest thing I could find was here: http://supportforums.blackberry.com/t5/Web-and-WebWorks-Development/Webapp-not-starting-on-device-VM... but it doesn't seem to have an answer [UPDATE: Adam Stanley mentioned that this was due to a missing Debug token, and this is not the case for me.])

 

When I attempt to "Package & Launch" from Ripple, the project builds properly and even installs onto the device (The icon for the application is on the home screen). However, when it attempts to launch the app, the Ripple console spits out:

 

"Error: Failed to create application process: Operation not permitted"

 

Any subsequent attempt to open the application from the icon on the screen will result in an immediate crash.

 

As an attempted work-around, I use "Package & Sign", and then run the blackberry-deploy tool with the -installApp and -launchApp options... it results in the same error as stated above.

 

I'm working on OS X, and I've properly installed the Webworks SDK as well as the Ripple Plugin on Chrome. I've got a project set up with a python web server running, and can view the contents properly on Ripple. I have my signing keys registered properly and I've generated the debugtoken.bar file. I've uploaded the debugtoken onto the dev alpha device successfully, and placed a copy of the debugtoken.bar file in the Webworks SDK root folder. The device is in developer mode as well.

 

Anyone have troubleshooting suggestions?

 

 

[Edited for format (initial post removed line breaks), and also to highlight a few things]

Retired
astanley
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Error: Failed to create application process: Operation not permitted -- Deploying from Ripple to Dev Alpha

"Failed to create application process"

 

That's a good message to troubleshoot - tells me the OS is unhappy about something, and its not a debug token issue.

 

Can you confirm some things for me?

 

> Is the version of the OS running on the Dev Alpha 10.0.9.388 (or higher)? If not, please update immedately. Using an older version of the OS may prevent apps from starting if thye were compiled using newer versions of the SDKs.

 

 

> Can you do a hard reset?  hold the power down on the Dev Alpha for 15+ seconds until the LED cycles.  That might restart any system process that may be out of whack (have seen it rarely in BETA software).

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.
New Contributor
Gnof
Posts: 4
Registered: ‎11-24-2012
My Device: Dev Alpha

Re: Error: Failed to create application process: Operation not permitted -- Deploying from Ripple to Dev Alpha

- Yep, definitely higher than 10.0.9.388 

 

- Hard reset was done, same issue. 

 

On the manual 'blackberry-deploy' call, (using a *signed* bar), this is the output:

 

Info: Sending request: Install and Launch
Info: Action: Install and Launch
Info: File size: 2976621
Info: Installing (obfuscatedappname).(obfuscated id)...
Info: Processing 2976621 bytes
Info: Progress 6%...
Info: Progress 44%...
Info: Progress 100%...
Info: Progress 100%...
actual_dname::smileysad:obfuscatedappname).(obfuscated id)
actual_id::smileysad:obfuscated id)
actual_version::3.0.0.7
result::success
Info: Launching (obfuscatedappname).(obfuscated id)...
Error: Failed to create application process: Operation not permitted

 

 

And on the ripple console, using "Package and Launch" (with a Debug Token installed), same thing as above (with a few more line breaks).

 

I've toyed around with the DebugTokens, and I've even reloaded the OS onto the device. 

 

Also, if this helps: I CAN run AIR applications through Flash Builder 4.6 with the AIR SDK set up using the same keys / tokens. (But this iOS app I'm porting is HTML5 :smileyhappy: )

 

(P.S. Thanks very much for the help so far!)

 

New Contributor
Gnof
Posts: 4
Registered: ‎11-24-2012
My Device: Dev Alpha

Re: Error: Failed to create application process: Operation not permitted -- Deploying from Ripple to Dev Alpha

On another note, I've also just tried setting up a brand-new environment on a windows machine, synced my project and attempted to deploy and I've had no luck. (Same Error message in the Ripple console)

 

I'll start eliminating device configuration settings as possible causes...

New Contributor
Gnof
Posts: 4
Registered: ‎11-24-2012
My Device: Dev Alpha

Re: Error: Failed to create application process: Operation not permitted -- Deploying from Ripple to Dev Alpha

So after coming back to the issue, I loaded build 1675 with the Webworks SDK (1.0.4.5) released today, and I was able to get past the permission error that plagued me previously.

 

Thanks again for the assistance Adam.