Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
mxberry
Posts: 37
Registered: ‎01-21-2012
My Device: Bold 9900
My Carrier: Iusacell

Re: Error Signing my App for Smartphones with WebWorks and Ripple

Tyvm LBP.

 

That worked for me.

 

Now i get an error window when the Java tool is staring the signing.

 

"Unable to create a temporary directory necessary for this application" 

Please use plain text.
Developer
The_Anomaly
Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: Error Signing my App for Smartphones with WebWorks and Ripple

There's a DOS window that opens when you start the ripple services.  Have a look at the text that fills that screen and see which folder its attempting to create that it can't.  I suspect its the package folder which you would have set in the settings button and form.

 

What I mean is everything you do in Ripple is displayed in that window.  Have a look through there or post some of it here for us to see - just REMOVE your passwords and personal stuff.

If it helped you, click like. :smileyhappy:
Please use plain text.
Contributor
mxberry
Posts: 37
Registered: ‎01-21-2012
My Device: Bold 9900
My Carrier: Iusacell

Re: Error Signing my App for Smartphones with WebWorks and Ripple

Ok so i asing some administrator permision to the SDK folder and subfolders and that worked!

 

The signature tool Runs but the window only marks 2/15 Signatures. But. I do get the 15 emails to my inbox of the 15 signatures so i guess the Java is just messed up. I also get the files on their folders and the zip file of the app! So i going to loaded OTA on my Bold 9900 and let you guys know later if it worked!

 



Please use plain text.
Contributor
mxberry
Posts: 37
Registered: ‎01-21-2012
My Device: Bold 9900
My Carrier: Iusacell

Re: Error Signing my App for Smartphones with WebWorks and Ripple

Ok well.. i guess the signing didn't worked... i try to open my app and it closed the first time saying that it can't be loaded. I try again and i get:

 

Error starting AppName Module 'AppName' attempts to access a secure API.

 

:No:

Please use plain text.
Developer
The_Anomaly
Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: Error Signing my App for Smartphones with WebWorks and Ripple

[ Edited ]

There's something missing from your config.xml or its a signing issue.  Based on your comments about the 2/15 I'd say something went wrong with the signing of the files.

 

Try another device.  If you emulating it in ripple try different devices.  Sometimes its only a particular device that gives trouble.  Which will help you narrow down the problem.

If it helped you, click like. :smileyhappy:
Please use plain text.
Contributor
mxberry
Posts: 37
Registered: ‎01-21-2012
My Device: Bold 9900
My Carrier: Iusacell

Re: Error Signing my App for Smartphones with WebWorks and Ripple

I try using another Simulator, This time a 9810 Simulator. I onlye get 1/15 Signatures. But i ghet all the 15 emails confirming the signatures.... On the Details of the Signature Tool Window has a message on the bottom:

 

Code file does not contain a signature from this SignerId. Please reques a signature. and a Path to a temp folder on my users.

 

:Online2long:

Please use plain text.
Developer
The_Anomaly
Posts: 322
Registered: ‎08-06-2012
My Device: Dev Alpha / Playbook / Curve 9300

Re: Error Signing my App for Smartphones with WebWorks and Ripple

Ok, first of all...

 

1.  Ripple likes to use a specific folder for development, are you using that folder?  It's in your Users folder and its called RippleSites.  So for eg:

C:\Users\The_Anomaly\RippleSites

 

2. Never test your app using a file location.  ie: in Ripple address bar it should read "localhost:9910/myapp/index.htm"  and NOT file://... - the localhost:9910 points to the ripplesites folder, the myapp will be the folder you put your app in, if you create one.

 

I'm also assuming you're using webworks and your app is in html5 because you're posting in this forum.  To some extent the 2 above may be different for different SDK's.  Can you confirm these 2 above?

If it helped you, click like. :smileyhappy:
Please use plain text.
New Developer
shivam284
Posts: 108
Registered: ‎01-23-2012
My Device: torch,bold,curve,strom
My Carrier: Blackberry

Re: Error Signing my App for Smartphones with WebWorks and Ripple

1st of all,
Start Ripple services
and in chrome inside the url bar, Write "localhost:9910/" and Press Enter.


It will create the RippleSites folder inside the User,
Place the project in RippleSites and check.


Hope this will be a solution for you.

Thanks & Regards,
Kumar Shivam
Please use plain text.
Contributor
mxberry
Posts: 37
Registered: ‎01-21-2012
My Device: Bold 9900
My Carrier: Iusacell

Re: Error Signing my App for Smartphones with WebWorks and Ripple

[ Edited ]

Hi. I am using RippleSites to run my app. Yes my app is writed on HTML5. The same App i have no trouble to do all this on the PlayBook SDK! It was fast and no problems at all. But for the Smartphone SDK this is just a nightmare! :smileysad:

Please use plain text.
BlackBerry Development Advisor
oros
Posts: 1,557
Registered: ‎04-12-2010
My Device: BlackBerry Z10
My Carrier: Bell

Re: Error Signing my App for Smartphones with WebWorks and Ripple

[ Edited ]

I haven't seen this mentioned yet, but can you please confirm which JDK you have installed in:
C:\Program Files (x86)\Java\

 

(Or if you are on a 32-bit machine, C:\Program Files\Java\)


The signature tool for Smartphones requires Java JDK 1.6 32-bit installed, otherwise it will run into issues during signing. The behaviour seems like a different JDK version (i.e. 1.7) or format (64-bit) may be installed, or potentially only the JRE and not JDK is installed.


Erik Oros | @WaterlooErik | eoros@blackberry.com | Developer Issue Tracker

If a reply has answered your question, please click Accept as Solution to help other visitors in the future.
Please use plain text.