Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
New Developer
mehmet
Posts: 17
Registered: ‎11-11-2009

Error Starting BlackBerry:Module 'net_rim_bb_browser_field2_api' not found

Hi,

 

I am trying to run a widget on my BlackBerry 8310 simulator VS 2008. I get following error message while launching the widget on the device

 

Error starting BlackBerry: Module 'net_rim_bb_browser_field2_api' not found.

 

what is it about and how can it be resolved?

Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,702
Registered: ‎10-16-2008
My Carrier: Rogers

Re: Error Starting BlackBerry:Module 'net_rim_bb_browser_field2_api' not found

The BlackBerry 8310 does not support the BlackBerry Operating System 5.0.

 

You must have a device that is running Operating System 5.0 to run a BlackBerry Widget

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
New Developer
mehmet
Posts: 17
Registered: ‎11-11-2009

Re: Error Starting BlackBerry:Module 'net_rim_bb_browser_field2_api' not found

Hi,

 

when i run the MDS Application in Visual Studio 2008,as default Blackberry 8310 display..

 

what can i do to have a device that is running Operating System 5.0 ??

Please use plain text.
BlackBerry Development Advisor
tneil
Posts: 3,702
Registered: ‎10-16-2008
My Carrier: Rogers

Re: Error Starting BlackBerry:Module 'net_rim_bb_browser_field2_api' not found

I think I'm a little confused and maybe we can get some clarification.

 

- Which version of the Visual Studio plug-in are you using?

- Are you trying to build an MDS Runtime application or a BlackBerry Widget?

 

From the sound of what you are describing you are trying to build an MDS Runtime application, but there should never be the use of the BrowserField2 API.  It is used for a BlackBerry widget

Tim Neil
Director, Application Platform & Tools Product Management
Follow me on Twitter
Please use plain text.
New Developer
mehmet
Posts: 17
Registered: ‎11-11-2009

Re: Error Starting BlackBerry:Module 'net_rim_bb_browser_field2_api' not found

i am using v1.1..

 

yes i build properly..

 

also,i run a sample application in sample browser, blackberry 8310 simulator display,i select widget API basic simple but i encounter same error..

 

 

Please use plain text.