Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
Posts: 31
Registered: ‎01-20-2011
My Device: Torch 9800
My Carrier: Bell

Error building WebWorks project on Mac OSX

Hello,

 

I have installed the Blackberry Webworks SDK successfully on Mac OSX 10.5.8.

 

When I try to execute the command, it comes up with the following error:

 

 

$ ./bbwp
dyld: unknown required load command 0x80000022
Trace/BPT trap
It seems that it is crashing:
20/01/11 7:44:32 PM ReportCrash[26116] Formulating crash report for process bbwp[26115] 
Here are the details of the crash report:
Process:         bbwp [26067]
Path:            ./bbwp
Identifier:      bbwp
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  bash [26011]
Date/Time:       2011-01-20 19:31:49.426 -0500
OS Version:      Mac OS X 10.5.8 (9L31a)
Report Version:  6
Anonymous UUID:  7F0BFC7A-2A58-40F0-B62E-A069D95AEB5C
Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0
Dyld Error Message:
  unknown required load command 0x80000022
Some assistance would be greatly appreciated.

Regards,
Moses
New Member
Posts: 1
Registered: ‎03-21-2011
My Device: Blackberry PlayBook
My Carrier: N/A

Re: Error building WebWorks project on Mac OSX

Got the same problem while building helloWorld sample Blackberry WebWorks app on my Mac OS X 10.5.8. Anybody found a solution to the problem yet?

$ ./bbwp
dyld: unknown required load command 0x80000022
Trace/BPT trap

Thanks!

Contributor
Posts: 31
Registered: ‎01-20-2011
My Device: Torch 9800
My Carrier: Bell

Re: Error building WebWorks project on Mac OSX

[ Edited ]

Yes, I did manage to find a solution.

 

Bypass the binary file and use the java jar file directly as follows:

 

java -jar /path/to/bbwp/bin/bbwp.jar app.zip

 

Good Luck!

Retired
Posts: 1,382
Registered: ‎07-02-2009
My Device: BlackBerry Bold 9900
My Carrier: Bell

Re: Error building WebWorks project on Mac OSX

Hi folks,  I think the fact that you are using Mac OSX 10.5.8 may be the problem.  As indicated in the system requirements, version 10.6.4+ is required:

 

http://docs.blackberry.com/en/developers/deliverables/23978/System_requirements_tablet_1429427_11.js...

 

Cheers,

Adam

Follow me on Twitter: @n_adam_stanley
-------------------------------------------------------------------------------------------------------------------------
Your app doesn't work? Use BlackBerry remote web inspector to find out why.