Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
Contributor
deedubbu
Posts: 35
Registered: ‎07-07-2011
My Device: Torch
Accepted Solution

Error configuring system for BB10 signing

I'm using the latest version of the BB10 WebWorks SDK (1.0.0.15) and am trying to configure my system (Mac OS X) for signing and debug tokens. I have previously setup my system for BB OS 5+ signing successfully. I have not previously configured my system for PlayBook signing. When I attempt to run the blackberry-signer from the command line I am receiving an error that author.p12 does not exist which is confusing since I thought blackberry-signer was suppose to create it:

 

$ ./blackberry-signer register -csjpin mypin -storepass mypass pathtoRDK.csj pathtoPBDT.csj
Enter Passphrase for keystore:
Error: Keystore load: /Users/myuser/Library/Research In Motion/author.p12 (No such file or directory)

 

Specifying the verbose flag does not produce any additional information.  Anyone know what is going on?

BlackBerry Development Advisor
twindsor
Posts: 832
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: Error configuring system for BB10 signing

The documentation has a "-register", not "register"?

 

I find it easier to use our Graphical Tool: http://supportforums.blackberry.com/t5/Testing-and-Deployment/BlackBerry-Tablet-OS-Graphical-Aid/ta-...

Tim Windsor
Open Source Technical Lead
Contributor
deedubbu
Posts: 35
Registered: ‎07-07-2011
My Device: Torch

Re: Error configuring system for BB10 signing

Wow, can't believe I didn't realize I left the '-' off of the register command. In my defense, the argument checking probably could be enhanced and a better error message thrown. Thanks, after fixing my user error it worked!

BlackBerry Development Advisor
twindsor
Posts: 832
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: Error configuring system for BB10 signing

Totally understand. That's why I always use the graphical tool myself :smileyhappy:

Tim Windsor
Open Source Technical Lead
Developer
Developer
LBP
Posts: 607
Registered: ‎04-29-2011
My Device: PlayBook 16GB, BB10 LE Z10 (red)
My Carrier: none

Re: Error configuring system for BB10 signing


twindsor wrote:

Totally understand. That's why I always use the graphical tool myself :smileyhappy:


Hi Tim. I would like to use the Graphical Tool myself, but is it already useable for BB10 SDK? When using the command line or Ripple 0.9.7 to sign for BB10 I always get the error reported here: http://supportforums.blackberry.com/t5/Testing-and-Deployment/Decrypt-Keystore-Password-suddenly-inv...

 

I researched the topics available in the forum but couldn't find the problem causing the error until now. On PB it is working really well using the PB SDK, but using the BB10 SDK signing fails every time, I can only use debug token to get it up running on the device for testing purposes.


"Like" if you liked the post.
"Accept as Solution" if the post solves your question.
BlackBerry Development Advisor
twindsor
Posts: 832
Registered: ‎07-15-2008
My Device: Passport
My Carrier: Bell

Re: Error configuring system for BB10 signing

That issue is outside of my expertise. I'd suggest going through our code signing help wizard and requesting to open a ticket. One of our code signing experts can help you out.

 

https://bdsc.webapps.blackberry.com/CodeSigningHelp/

Tim Windsor
Open Source Technical Lead