Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Web and WebWorks Development

Reply
BlackBerry Development Advisor
bryanhiggins
Posts: 203
Registered: ‎12-18-2012
My Device: Z10, Q10, Q5, Z30, Z3

Re: Error when “cordova emulate blackberry10”

The auto-detection of simulator is failing. It expects the simulator to be configured by DHCP and uses this file to look up the address:

 

C:\Users\All Users\VMware\vmnetdhcp.leases

 

An alternative is to configure a target:

 

platforms\blackberry10\cordova\target add <ip address> mysim -t simulator --pin <simulator PIN>

cordova emulate blackberry10 --target=mysim

Bryan Higgins
BlackBerry WebWorks
@bryanhiggins
Contributor
janot
Posts: 12
Registered: ‎02-20-2013
My Device: Dev Alpha B

Re: Error when “cordova emulate blackberry10”

[ Edited ]

I don't have such folder "C:\Users\All Users\"

 

You have typo in command: mysim should be before <ip address>

 

It's working now :smileyhappy: Thank you

If you're SO user (seems that I found your account there) you may post this as answer in my question here http://stackoverflow.com/q/19983171/1548085

BlackBerry Development Advisor
bryanhiggins
Posts: 203
Registered: ‎12-18-2012
My Device: Z10, Q10, Q5, Z30, Z3

Re: Error when “cordova emulate blackberry10”

Which version of Windows are you running?

 

The actualy path is looks for is %USERPROFILE%/../All Users

Bryan Higgins
BlackBerry WebWorks
@bryanhiggins
Contributor
janot
Posts: 12
Registered: ‎02-20-2013
My Device: Dev Alpha B

Re: Error when “cordova emulate blackberry10”

Win 8.1 x64

"%USERPROFILE%/../All Users" shows it, but it's not visible in "Users" folder with all possible checkboxes marked in "Folder Options". That's why I thought it doesn't exist